aboutsummaryrefslogtreecommitdiff
path: root/x11/keylaunch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/keylaunch/Makefile')
-rw-r--r--x11/keylaunch/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/x11/keylaunch/Makefile b/x11/keylaunch/Makefile
index 25e498b568e1..fdc8c8d9b815 100644
--- a/x11/keylaunch/Makefile
+++ b/x11/keylaunch/Makefile
@@ -11,25 +11,18 @@ MAINTAINER= mwm@mired.org
COMMENT= An X utility for binding commands to a hot key
WRKSRC= ${WRKDIR}/keylaunch
-USE_GMAKE= yes
-USES= perl5
+USES= perl5 gmake
USE_PERL5= build
USE_XORG= x11
-PKGMESSAGE= ${WRKSRC}/pkg-message
+SUB_FILES= pkg-message
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -i '' -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/keylaunch ${PREFIX}/bin
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/example_rc ${EXAMPLESDIR}/keylaunch.rc
-
-post-install:
- @${SED} -e 's;/usr/X11R6;${LOCALBASE};g' < ${FILESDIR}/pkg-message.in > \
- ${PKGMESSAGE}
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/keylaunch ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example_rc ${STAGEDIR}${EXAMPLESDIR}/keylaunch.rc
.include <bsd.port.mk>