aboutsummaryrefslogtreecommitdiff
path: root/x11/libXi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libXi/Makefile')
-rw-r--r--x11/libXi/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/x11/libXi/Makefile b/x11/libXi/Makefile
index 3aaa0239733b..b36c6f4c4220 100644
--- a/x11/libXi/Makefile
+++ b/x11/libXi/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: libXi
-# Date Created: 22 Nov, 2003
-# Whom: Eric Anholt <anholt@FreeBSD.org>
-#
+# Created by: Eric Anholt <anholt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libXi
-PORTVERSION= 1.4.5
+PORTVERSION= 1.7.1
PORTEPOCH= 1
CATEGORIES= x11
@@ -16,9 +12,14 @@ COMMENT= X Input extension library
LICENSE= MIT
XORG_CAT= lib
-USE_XORG= xproto x11 xext xextproto inputproto:both
+USE_XORG= xproto x11 xext xextproto xfixes inputproto:both
-CONFIGURE_ARGS+=--disable-specs --without-xmlto
+CONFIGURE_ARGS+=--disable-docs \
+ --disable-specs \
+ --without-xmlto \
+ --without-fop \
+ --without-asciidoc \
+ --without-xsltproc
MAN3= XAllowDeviceEvents.3 \
XChangeDeviceControl.3 \
@@ -47,6 +48,8 @@ MAN3= XAllowDeviceEvents.3 \
XGrabDevice.3\
XGrabDeviceButton.3\
XGrabDeviceKey.3\
+ XIBarrierReleasePointer.3\
+ XIBarrierReleasePointers.3\
XIChangeHierarchy.3\
XIChangeProperty.3\
XIDefineCursor.3\
@@ -61,6 +64,7 @@ MAN3= XAllowDeviceEvents.3 \
XIGrabEnter.3\
XIGrabFocusIn.3\
XIGrabKeycode.3\
+ XIGrabTouchBegin.3 \
XIListProperties.3\
XIQueryDevice.3\
XIQueryPointer.3\
@@ -74,6 +78,7 @@ MAN3= XAllowDeviceEvents.3 \
XIUngrabEnter.3 \
XIUngrabFocusIn.3 \
XIUngrabKeycode.3 \
+ XIUngrabTouchBegin.3 \
XIWarpPointer.3 \
XListDeviceProperties.3 \
XListInputDevices.3 \