aboutsummaryrefslogtreecommitdiff
path: root/x11/libdnd
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libdnd')
-rw-r--r--x11/libdnd/Makefile37
-rw-r--r--x11/libdnd/distinfo2
-rw-r--r--x11/libdnd/files/patch-DragAndDrop.c57
-rw-r--r--x11/libdnd/files/patch-Makefile.in68
-rw-r--r--x11/libdnd/files/patch-configure20
-rw-r--r--x11/libdnd/pkg-descr3
-rw-r--r--x11/libdnd/pkg-plist12
7 files changed, 0 insertions, 199 deletions
diff --git a/x11/libdnd/Makefile b/x11/libdnd/Makefile
deleted file mode 100644
index 4802e296677c..000000000000
--- a/x11/libdnd/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# Created by: lukin@okbmei.msk.su
-# $FreeBSD$
-
-PORTNAME= libdnd
-PORTVERSION= 1.1
-PORTREVISION= 5
-CATEGORIES= x11
-MASTER_SITES= http://leb.net/offix/
-DISTNAME= dnd.${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Drag and drop library
-
-LICENSE= LGPL20
-LICENSE_FILE= ${WRKSRC}/../COPYING.LIB
-
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-07-04
-
-USES= tar:tgz
-USE_XORG= x11 xmu ice xaw
-USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/DND/DNDlib
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include/
-LDFLAGS+= -L${LOCALBASE}/lib/
-MAKE_JOBS_UNSAFE= yes
-
-OPTIONS_DEFINE= DOCS
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKDIR}/DND/DNDdoc/* ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/x11/libdnd/distinfo b/x11/libdnd/distinfo
deleted file mode 100644
index eaf3d37f82a7..000000000000
--- a/x11/libdnd/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (dnd.1.1.tgz) = ffd9b74f1bf8e5c18a4745ef89e9c6618f9507ec09a010c4bf15481a3f130804
-SIZE (dnd.1.1.tgz) = 227598
diff --git a/x11/libdnd/files/patch-DragAndDrop.c b/x11/libdnd/files/patch-DragAndDrop.c
deleted file mode 100644
index b00afd5333d9..000000000000
--- a/x11/libdnd/files/patch-DragAndDrop.c
+++ /dev/null
@@ -1,57 +0,0 @@
---- DragAndDrop.c.orig Fri Nov 22 19:19:27 1996
-+++ DragAndDrop.c Sat Feb 26 22:03:14 2000
-@@ -22,7 +22,12 @@
- #include <X11/Xmu/WinUtil.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__)
-+#include <limits.h>
-+#define MAXINT INT_MAX
-+#else
- #include <values.h>
-+#endif
-
- /* Local variables */
- static Display *dpy; /* current display */
-@@ -81,23 +86,23 @@
-
- static CursorData DndCursor[DndEND]={
- { 0,0,NULL,NULL,0,0,0 },
-- { grey_width, grey_height,grey_bits,grey_mask_bits,
-+ { grey_width, grey_height,(char *)grey_bits,(char *)grey_mask_bits,
- grey_x_hot,grey_y_hot},
-- { file_width,file_height,file_bits,file_mask_bits,
-+ { file_width,file_height,(char *)file_bits,(char *)file_mask_bits,
- file_x_hot,file_y_hot},
-- { files_width,files_height,files_bits,files_mask_bits,
-+ { files_width,files_height,(char *)files_bits,(char *)files_mask_bits,
- files_x_hot,files_y_hot},
-- { text_width,text_height,text_bits,text_mask_bits,
-+ { text_width,text_height,(char *)text_bits,(char *)text_mask_bits,
- text_x_hot,text_y_hot },
-- { dir_width,dir_height,dir_bits,dir_mask_bits,
-+ { dir_width,dir_height,(char *)dir_bits,(char *)dir_mask_bits,
- dir_x_hot,dir_y_hot },
-- { link_width,link_height,link_bits,link_mask_bits,
-+ { link_width,link_height,(char *)link_bits,(char *)link_mask_bits,
- link_x_hot,link_y_hot},
-- { app_width,app_height,app_bits,app_mask_bits,
-+ { app_width,app_height,(char *)app_bits,(char *)app_mask_bits,
- app_x_hot,app_y_hot },
-- { url_width,url_height,url_bits,url_mask_bits,
-+ { url_width,url_height,(char *)url_bits,(char *)url_mask_bits,
- url_x_hot,url_y_hot },
-- { mime_width,mime_height,mime_bits,mime_mask_bits,
-+ { mime_width,mime_height,(char *)mime_bits,(char *)mime_mask_bits,
- mime_x_hot,mime_y_hot }
- };
-
-@@ -394,7 +399,7 @@
- if(MainWidget) return MainWidget;
- #ifdef DEBUG
- fprintf(stderr,"Multiple shells.\n");
--#endif DEBUG
-+#endif
-
- while(XtParent(widget) && XtIsRealized(XtParent(widget))==True)
- widget=XtParent(widget);
diff --git a/x11/libdnd/files/patch-Makefile.in b/x11/libdnd/files/patch-Makefile.in
deleted file mode 100644
index 0fbdb3549d4f..000000000000
--- a/x11/libdnd/files/patch-Makefile.in
+++ /dev/null
@@ -1,68 +0,0 @@
---- Makefile.in.orig 1997-05-23 10:18:22.000000000 +0800
-+++ Makefile.in 2014-01-09 20:47:32.000000000 +0800
-@@ -13,6 +13,10 @@ LDFLAGS = @LDFLAGS@
- RANLIB = @RANLIB@
-
- LIBS = @LIBS@ @X_LIBS@ @X_PRE_LIBS@ -lXmu -lXaw -lXt -lX11 @X_EXTRA_LIBS@
-+LIBS+= -Wl,-rpath,$(LOCALBASE)/lib
-+SHLDFLAGS= -shared -x -soname $@
-+DNDLIB= libDnd.so.1
-+DNDPLUSLIB= libDnd++.so.1
-
- prefix = @prefix@
- exec_prefix = @exec_prefix@
-@@ -23,20 +27,30 @@ COMPILE = $(CC) $(INCLUDES) $(CFLAGS) -c
- CXXCOMPILE = $(CXX) $(INCLUDES) $(CXXFLAGS) -c
- LINK = $(CC) $(LDFLAGS) -o $@
-
-+SOCOMPILE= $(COMPILE) -fpic
-+SOCXXCOMPILE = $(CXX) $(INCLUDES) $(CXXFLAGS) -c -fpic
-+
- default: all
-
--all: libC libCpp dndtest
-+all: libC libCpp dndtest libC-so libCpp-so
-
- install: libCpp libC
-- install -d $(INC_DIR)
-- install DragAndDrop.h DragAndDropTypes.h $(INC_DIR)
-- install -d $(LIB_DIR)
-- install libDnd.a libDnd++.a $(LIB_DIR)
-+ install -d $(DESTDIR)$(INC_DIR)
-+ install -c -m 644 DragAndDrop.h DragAndDropTypes.h $(DESTDIR)$(INC_DIR)
-+ install -d $(DESTDIR)$(LIB_DIR)
-+ install -c -m 644 libDnd.a libDnd++.a $(DESTDIR)$(LIB_DIR)
-+ install -c $(DNDLIB) $(DNDPLUSLIB) $(DESTDIR)$(LIB_DIR)
-+ cd $(DESTDIR)/$(LIB_DIR); ln -sf $(DNDLIB) libDnd.so
-+ cd $(DESTDIR)/$(LIB_DIR); ln -sf $(DNDPLUSLIB) libDnd++.so
-
- libC: libDnd.a
-
- libCpp: libDnd++.a
-
-+libC-so: $(DNDLIB)
-+
-+libCpp-so: $(DNDPLUSLIB)
-+
- dndtest: dndtest.c libDnd.a
- rm -f dndtest
- $(COMPILE) dndtest.c
-@@ -57,6 +71,16 @@ libDnd++.a: DragAndDrop.c
- $(AR) cru libDnd++.a DragAndDrop.o
- $(RANLIB) libDnd++.a
-
--clean:
-- rm -f *.o *.cxx *.a dndtest *~ *bak
-+$(DNDLIB): DragAndDrop.c
-+ rm -f DragAndDrop.so
-+ $(SOCOMPILE) -o DragAndDrop.so DragAndDrop.c
-+ $(LD) $(SHLDFLAGS) -o $(DNDLIB) DragAndDrop.so
-
-+$(DNDPLUSLIB): DragAndDrop.c
-+ rm -f DragAndDrop.so DragAndDrop.cxx
-+ ln -s DragAndDrop.c DragAndDrop.cxx
-+ $(SOCXXCOMPILE) -o DragAndDrop.so DragAndDrop.cxx
-+ $(LD) $(SHLDFLAGS) -o $(DNDPLUSLIB) DragAndDrop.so
-+
-+clean:
-+ rm -f *.o *.so *.cxx *.a dndtest *~ *bak
diff --git a/x11/libdnd/files/patch-configure b/x11/libdnd/files/patch-configure
deleted file mode 100644
index e7edc649095c..000000000000
--- a/x11/libdnd/files/patch-configure
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig 1997-05-24 09:28:20.000000000 +0200
-+++ configure 2011-09-12 22:35:36.000000000 +0200
-@@ -612,7 +612,7 @@
- cat > conftest.$ac_ext <<EOF
- #line 614 "configure"
- #include "confdefs.h"
--main(){return(0);}
-+int main(){return(0);}
- EOF
- if { (eval echo configure:618: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
- ac_cv_prog_cc_works=yes
-@@ -738,7 +738,7 @@
- cat > conftest.$ac_ext <<EOF
- #line 740 "configure"
- #include "confdefs.h"
--main(){return(0);}
-+int main(){return(0);}
- EOF
- if { (eval echo configure:744: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
- ac_cv_prog_cxx_works=yes
diff --git a/x11/libdnd/pkg-descr b/x11/libdnd/pkg-descr
deleted file mode 100644
index 1923470dafcf..000000000000
--- a/x11/libdnd/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-This library allows to use drag and drop protocol with any X program.
-The protocol in question - DND - is developed by Cesar Crucius. OffiX
-applications use this protocol, for example.
diff --git a/x11/libdnd/pkg-plist b/x11/libdnd/pkg-plist
deleted file mode 100644
index 87f895649117..000000000000
--- a/x11/libdnd/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-include/OffiX/DragAndDrop.h
-include/OffiX/DragAndDropTypes.h
-lib/libDnd++.a
-lib/libDnd++.so
-lib/libDnd++.so.1
-lib/libDnd.a
-lib/libDnd.so
-lib/libDnd.so.1
-%%PORTDOCS%%%%DOCSDIR%%/DND.dvi
-%%PORTDOCS%%%%DOCSDIR%%/DNDa4.ps
-%%PORTDOCS%%%%DOCSDIR%%/DNDletter.ps
-%%PORTDOCS%%%%DOCSDIR%%/README