aboutsummaryrefslogtreecommitdiff
path: root/x11/libexo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libexo/Makefile')
-rw-r--r--x11/libexo/Makefile35
1 files changed, 9 insertions, 26 deletions
diff --git a/x11/libexo/Makefile b/x11/libexo/Makefile
index 645b5e6af26b..63144d081655 100644
--- a/x11/libexo/Makefile
+++ b/x11/libexo/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= libexo
-PORTVERSION= 0.10.2
-PORTREVISION= 5
+PORTVERSION= 0.10.3
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR= src/xfce/exo/${PORTVERSION:R}
DISTNAME= exo-${PORTVERSION}
DIST_SUBDIR= xfce4
@@ -22,38 +20,23 @@ BUILD_DEPENDS= p5-URI>=1.60:${PORTSDIR}/net/p5-URI
RUN_DEPENDS= p5-URI>=1.60:${PORTSDIR}/net/p5-URI
WRKSRC= ${WRKDIR}/${DISTNAME}
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/lib//}
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
USES= desktop-file-utils gmake libtool pathfix perl5 \
- pkgconfig tar:bzip2
+ pkgconfig gettext-tools xfce tar:bzip2
USE_GNOME= glib20 gtk20 intltool intlhack
USE_LDCONFIG= yes
-USE_XFCE= configenv libmenu libutil
+USE_XFCE= libmenu
USE_XORG= x11
-OPTIONS_DEFINE= DOCS NLS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+=--with-html-dir=${PREFIX}/share/gtk-doc/html
-PLIST_SUB+= APIDOCS=""
-.else
-CONFIGURE_ARGS+=--without-html-dir
-PLIST_SUB+= APIDOCS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+CONFIGURE_ARGS=--without-html-dir
+
+OPTIONS_DEFINE= NLS
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
+OPTIONS_SUB= yes
post-patch:
${REINPLACE_CMD} -e 's|internet-mail|mail-send|' \