aboutsummaryrefslogtreecommitdiff
path: root/x11/libgnome/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libgnome/Makefile')
-rw-r--r--x11/libgnome/Makefile29
1 files changed, 25 insertions, 4 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index d752f7c6c44c..4bb69b27dbab 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= libgnome
-PORTVERSION= 2.6.1.2
-CATEGORIES?= x11 gnome
+PORTVERSION= 2.8.0
+CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.6
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.8
DIST_SUBDIR= gnome2
-MAINTAINER?= gnome@FreeBSD.org
+MAINTAINER= gnome@FreeBSD.org
COMMENT= Libraries for GNOME, a GNU desktop environment
BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
@@ -20,6 +20,7 @@ RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_XPM= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier intlhack esound \
@@ -30,4 +31,24 @@ USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+GCONF_SCHEMAS= desktop_gnome_accessibility_keyboard.schemas \
+ desktop_gnome_accessibility_startup.schemas \
+ desktop_gnome_applications_browser.schemas \
+ desktop_gnome_applications_help_viewer.schemas \
+ desktop_gnome_applications_terminal.schemas \
+ desktop_gnome_applications_window_manager.schemas \
+ desktop_gnome_background.schemas \
+ desktop_gnome_file_views.schemas \
+ desktop_gnome_interface.schemas desktop_gnome_lockdown.schemas \
+ desktop_gnome_peripherals_keyboard.schemas \
+ desktop_gnome_peripherals_mouse.schemas \
+ desktop_gnome_sound.schemas desktop_gnome_thumbnailers.schemas \
+ desktop_gnome_typing_break.schemas
+
+.if defined(NOPORTDOCS)
+post-patch:
+ @${REINPLACE_CMD} -e 's|gnome-data po doc|gnome-data po|g' \
+ ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>