aboutsummaryrefslogtreecommitdiff
path: root/x11/libgnomekbd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libgnomekbd/Makefile')
-rw-r--r--x11/libgnomekbd/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11/libgnomekbd/Makefile b/x11/libgnomekbd/Makefile
new file mode 100644
index 000000000000..db661e438d67
--- /dev/null
+++ b/x11/libgnomekbd/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libgnomekbd
+# Date created: 2006-11-07
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/x11/libgnomekbd/Makefile,v 1.5 2007/03/12 01:37:17 mezz Exp $
+#
+
+PORTNAME= libgnomekbd
+PORTVERSION= 2.18.0
+CATEGORIES= x11 gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME keyboard shared library
+
+LIB_DEPENDS= xklavier.11:${PORTSDIR}/x11/libxklavier \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+
+USE_BZIP2= yes
+USE_GNOME= libgnomeui gnometarget gnomeprefix gnomehack
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+
+GCONF_SCHEMAS= desktop_gnome_peripherals_keyboard_xkb.schemas
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.mk>