aboutsummaryrefslogtreecommitdiff
path: root/x11/libxcb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libxcb/Makefile')
-rw-r--r--x11/libxcb/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/x11/libxcb/Makefile b/x11/libxcb/Makefile
index bbc6de655626..e594e63e0f03 100644
--- a/x11/libxcb/Makefile
+++ b/x11/libxcb/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libxcb
-PORTVERSION= 0.9.92
+PORTVERSION= 1.0
CATEGORIES= x11
MASTER_SITES= http://xcb.freedesktop.org/dist/
@@ -15,7 +15,9 @@ COMMENT= The X protocol C-language Binding (XCB) library
BUILD_DEPENDS= ${LIB_PC_DEPENDS} \
${LOCALBASE}/lib/libcheck.a:${PORTSDIR}/devel/libcheck \
- xsltproc:${PORTSDIR}/textproc/libxslt
+ xsltproc:${PORTSDIR}/textproc/libxslt \
+ doxygen:${PORTSDIR}/devel/doxygen \
+ dot:${PORTSDIR}/graphics/graphviz
RUN_DEPENDS= ${LIB_PC_DEPENDS}
USE_X_PREFIX= yes
@@ -27,15 +29,18 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-check=${LOCALBASE}
-.for f in XPROTO_CFLAGS XPROTO_LIBS XDMCP_CFLAGS XDMCP_LIBS XAU_CFLAGS XAU_LIBS
+.for f in XPROTO_CFLAGS XPROTO_LIBS XDMCP_CFLAGS XDMCP_LIBS NEEDED_CFLAGS NEEDED_LIBS
CONFIGURE_ARGS+=${f}="${${f}}"
.endfor
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
-LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xcb-proto.pc:${PORTSDIR}/x11/xcb-proto
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xcb-proto.pc:${PORTSDIR}/x11/xcb-proto \
+ ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:${PORTSDIR}/devel/libpthread-stubs
-XAU_CFLAGS= -I${X11BASE}/include
-XAU_LIBS= -L${X11BASE}/lib -lXau
+PTHREAD_STUBS_LIBS!= pkg-config --libs pthread-stubs
+
+NEEDED_CFLAGS= -I${X11BASE}/include
+NEEDED_LIBS= -L${X11BASE}/lib -lXau $(PTHREAD_STUBS_LIBS)
XDMCP_CFLAGS= -I${X11BASE}/include
XDMCP_LIBS= -L${X11BASE}/lib -lXdmcp