aboutsummaryrefslogtreecommitdiff
path: root/x11/libxklavier/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libxklavier/Makefile')
-rw-r--r--x11/libxklavier/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/x11/libxklavier/Makefile b/x11/libxklavier/Makefile
index 2b5cc7d61a67..46030a627ffd 100644
--- a/x11/libxklavier/Makefile
+++ b/x11/libxklavier/Makefile
@@ -3,30 +3,32 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/x11/libxklavier/Makefile,v 1.28 2006/09/10 00:51:15 mezz Exp $
#
PORTNAME= libxklavier
-PORTVERSION= 2.2
-PORTREVISION= 1
+PORTVERSION= 2.91
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.2
-DIST_SUBDIR= gnome2
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gswitchit
MAINTAINER= gnome@FreeBSD.org
COMMENT= An utility library to make XKB stuff easier
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gnomehack libxml2
-INSTALLS_SHLIB= yes
+USE_GNOME= gnometarget gnomehack libxml2 glib20
+USE_LDCONFIG= yes
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
CONFIGURE_ARGS= --disable-doxygen \
--with-xkb-base=${X11BASE}/lib/X11/xkb \
- --with-xmodmap-base=${X11BASE}/share/gnome/xmodmap
+ --with-xmodmap-base=${LOCALBASE}/share/gnome/xmodmap \
+ --disable-gtk-doc \
+ --with-html-dir=${GNOME_HTML_DIR}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"