aboutsummaryrefslogtreecommitdiff
path: root/x11/mate-panel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/mate-panel/Makefile')
-rw-r--r--x11/mate-panel/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/x11/mate-panel/Makefile b/x11/mate-panel/Makefile
index cf1f5acbee7e..0092fed196e6 100644
--- a/x11/mate-panel/Makefile
+++ b/x11/mate-panel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mate-panel
PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -17,16 +17,14 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
PORTSCOUT= limitw:1,even
-USES= gettext gmake pathfix pkgconfig
-USE_XZ= yes
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
USE_MATE= desktop docutils libmateweather libmatewnck menus
USE_XORG= ice sm x11 xau xrandr
USE_GNOME= cairo dconf gdkpixbuf2 glib20 gnomehier gtk20 \
- intlhack introspection:build librsvg2 ltverhack pango
+ intlhack introspection:build librsvg2 pango
USE_PYTHON= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-network-manager \
--disable-gtk-doc \
@@ -35,6 +33,7 @@ CONFIGURE_ARGS= --disable-network-manager \
INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
+INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.mate.panel.applet.clock.gschema.xml \
org.mate.panel.applet.fish.gschema.xml \
@@ -47,6 +46,5 @@ GLIB_SCHEMAS= org.mate.panel.applet.clock.gschema.xml \
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/mate-panel/modules
- @${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/libmate-panel-applet-4.so.1
.include <bsd.port.mk>