aboutsummaryrefslogtreecommitdiff
path: root/x11/plasma5-kactivitymanagerd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/plasma5-kactivitymanagerd/Makefile')
-rw-r--r--x11/plasma5-kactivitymanagerd/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/x11/plasma5-kactivitymanagerd/Makefile b/x11/plasma5-kactivitymanagerd/Makefile
new file mode 100644
index 000000000000..70809492aca8
--- /dev/null
+++ b/x11/plasma5-kactivitymanagerd/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= kactivitymanagerd
+DISTVERSION= ${KDE_PLASMA_VERSION}
+CATEGORIES= x11 kde kde-plasma
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= System service to manage user's activities, track the usage patterns
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= auth codecs config configwidgets coreaddons dbusaddons ecm \
+ globalaccel i18n kio service widgetsaddons windowsystem xmlgui
+USE_QT5= concurrent core dbus gui network sql widgets xml \
+ buildtools_build qmake_build
+
+# https://bugs.kde.org/show_bug.cgi?id=305529#c10
+CMAKE_ARGS+= -DCMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS=-rdynamic
+
+.include <bsd.port.mk>