aboutsummaryrefslogtreecommitdiff
path: root/x11/qt4-inputmethods/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/qt4-inputmethods/Makefile')
-rw-r--r--x11/qt4-inputmethods/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
index f836361f37bb..c9b569ce84ad 100644
--- a/x11/qt4-inputmethods/Makefile
+++ b/x11/qt4-inputmethods/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt input method plugins
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc corelib gui
+QT_COMPONENTS= qmake_build moc_build corelib gui
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -43,8 +43,6 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../..
-.include <bsd.port.pre.mk>
-
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib/plugins/inputmethods|g' \
@@ -53,4 +51,4 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>