aboutsummaryrefslogtreecommitdiff
path: root/x11/rxvt-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/rxvt-devel/Makefile')
-rw-r--r--x11/rxvt-devel/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/x11/rxvt-devel/Makefile b/x11/rxvt-devel/Makefile
index b4378eb98c82..9f333337c927 100644
--- a/x11/rxvt-devel/Makefile
+++ b/x11/rxvt-devel/Makefile
@@ -13,6 +13,7 @@ COMMENT= Low memory usage xterm replacement that supports color
USE_AUTOTOOLS= libtool
USES= perl5
+USE_LDCONFIG= yes
USE_PERL5= build patch
USE_XORG= xpm
GNU_CONFIGURE= yes
@@ -39,7 +40,7 @@ XTERM_DESC= Build with Xterm scrollbar
CONFIGURE_ARGS= --enable-utmp --enable-lastlog \
--with-xpm --enable-xpm-background --enable-shared \
--enable-mousewheel --disable-languages
-USE_LDCONFIG= yes
+LIBS+= -lutil
.include <bsd.port.pre.mk>
@@ -131,8 +132,6 @@ CONFIGURE_ARGS+= --enable-xim
CONFIGURE_ARGS+= --enable-xterm-scroll
.endif
-CONFIGURE_ENV+= LIBS="-lutil"
-
post-patch:
@${PERL} -pi -e 's|(PTYCHAR2\s+"[^"]+)"|\1ghijklmnopqrstuv"|' \
${WRKSRC}/src/ptytty.c