aboutsummaryrefslogtreecommitdiff
path: root/x11/rxvt-devel
diff options
context:
space:
mode:
Diffstat (limited to 'x11/rxvt-devel')
-rw-r--r--x11/rxvt-devel/Makefile2
-rw-r--r--x11/rxvt-devel/files/patch-src::logging.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/x11/rxvt-devel/Makefile b/x11/rxvt-devel/Makefile
index 8e34d7fb40e5..bbf9baf253ce 100644
--- a/x11/rxvt-devel/Makefile
+++ b/x11/rxvt-devel/Makefile
@@ -9,7 +9,7 @@
PORTNAME= rxvt
PORTVERSION= 2.7.10
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES+= x11
MASTER_SITES= SF
PKGNAMESUFFIX= -devel
diff --git a/x11/rxvt-devel/files/patch-src::logging.c b/x11/rxvt-devel/files/patch-src::logging.c
new file mode 100644
index 000000000000..20f9e436a24a
--- /dev/null
+++ b/x11/rxvt-devel/files/patch-src::logging.c
@@ -0,0 +1,12 @@
+--- src/logging.c
++++ src/logging.c
+@@ -82,7 +82,8 @@
+ else if (sscanf(pty, "pts/%d", &i) == 1)
+ sprintf(ut_id, "vt%02x", (i & 0xff)); /* sysv naming */
+ #endif
+- else if (STRNCMP(pty, "pty", 3) && STRNCMP(pty, "tty", 3)) {
++ else if (STRNCMP(pty, "pty", 3) && STRNCMP(pty, "tty", 3) &&
++ STRNCMP(pty, "pts/", 4)) {
+ rxvt_print_error("can't parse tty name \"%s\"", pty);
+ return;
+ }