aboutsummaryrefslogtreecommitdiff
path: root/x11/rxvt-unicode
diff options
context:
space:
mode:
Diffstat (limited to 'x11/rxvt-unicode')
-rw-r--r--x11/rxvt-unicode/Makefile2
-rw-r--r--x11/rxvt-unicode/distinfo4
-rw-r--r--x11/rxvt-unicode/files/patch-src::command.C10
3 files changed, 8 insertions, 8 deletions
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 678f9dc5481c..3b3af817c80f 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rxvt-unicode
-PORTVERSION= 9.14
+PORTVERSION= 9.15
CATEGORIES= x11
MASTER_SITES= http://dist.schmorp.de/rxvt-unicode/%SUBDIR%/
MASTER_SITE_SUBDIR= . Attic
diff --git a/x11/rxvt-unicode/distinfo b/x11/rxvt-unicode/distinfo
index 83cb1c97cc14..05e9616f33c9 100644
--- a/x11/rxvt-unicode/distinfo
+++ b/x11/rxvt-unicode/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rxvt-unicode-9.14.tar.bz2) = 29928a33be6b3fb0edd126df2c3d35e1900f8268b546ce54430780c550fa1d52
-SIZE (rxvt-unicode-9.14.tar.bz2) = 894702
+SHA256 (rxvt-unicode-9.15.tar.bz2) = ec1aa2932da844979ed8140bd92223defb12042aa5e877e05ac31139ca81f2b1
+SIZE (rxvt-unicode-9.15.tar.bz2) = 894764
diff --git a/x11/rxvt-unicode/files/patch-src::command.C b/x11/rxvt-unicode/files/patch-src::command.C
index f6fa8658b88d..748f2aaec7e9 100644
--- a/x11/rxvt-unicode/files/patch-src::command.C
+++ b/x11/rxvt-unicode/files/patch-src::command.C
@@ -1,14 +1,14 @@
---- src/command.C.orig 2011-06-22 14:44:37.000000000 +0400
-+++ src/command.C 2011-09-21 15:39:21.000000000 +0400
+--- src/command.C.orig 2012-01-19 14:34:39.000000000 +0100
++++ src/command.C 2012-01-23 19:28:46.000000000 +0100
@@ -57,6 +57,7 @@
#endif
- #include <csignal>
+ #include <signal.h>
+#include <sys/param.h>
#if LINUX_YIELD_HACK
- # include <ctime>
-@@ -2357,7 +2358,9 @@
+ # include <time.h>
+@@ -2354,7 +2355,9 @@
if (len == (size_t)-2)
{
// the mbstate stores incomplete sequences. didn't know this :/