aboutsummaryrefslogtreecommitdiff
path: root/x11/slop
diff options
context:
space:
mode:
Diffstat (limited to 'x11/slop')
-rw-r--r--x11/slop/Makefile24
-rw-r--r--x11/slop/distinfo2
-rw-r--r--x11/slop/pkg-descr4
3 files changed, 30 insertions, 0 deletions
diff --git a/x11/slop/Makefile b/x11/slop/Makefile
new file mode 100644
index 000000000000..1e2bf7f3f237
--- /dev/null
+++ b/x11/slop/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= slop
+PORTVERSION= 4.1.15
+CATEGORIES= x11
+
+MAINTAINER= neel@neelc.org
+COMMENT= Make a screen selection and print the selection coordinates to stdout
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= naelstrof
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= cbc1856
+
+USES= cmake
+USE_XORG= x11 xext
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/slop ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/slop/distinfo b/x11/slop/distinfo
new file mode 100644
index 000000000000..870f3890a99d
--- /dev/null
+++ b/x11/slop/distinfo
@@ -0,0 +1,2 @@
+SHA256 (slop-4.1.15.tar.gz) = fd7c1a7564c228a0a78954559bfd6b0f1f55730e6461891900dd7912e2eaf9b8
+SIZE (slop-4.1.15.tar.gz) = 35302
diff --git a/x11/slop/pkg-descr b/x11/slop/pkg-descr
new file mode 100644
index 000000000000..a344d7d79afc
--- /dev/null
+++ b/x11/slop/pkg-descr
@@ -0,0 +1,4 @@
+slop (Select Operation) is an application that collects a screen selection
+from the user and prints the selection's coordinates to stdout.
+
+WWW: http://www.github.com/naelstrof/slop