aboutsummaryrefslogtreecommitdiff
path: root/x11/wbar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/wbar/Makefile')
-rw-r--r--x11/wbar/Makefile35
1 files changed, 19 insertions, 16 deletions
diff --git a/x11/wbar/Makefile b/x11/wbar/Makefile
index afe3f5db7b9f..d249f273da73 100644
--- a/x11/wbar/Makefile
+++ b/x11/wbar/Makefile
@@ -6,31 +6,34 @@
#
PORTNAME= wbar
-PORTVERSION= 1.3.3
-PORTREVISION= 4
+PORTVERSION= 2.2.2
+PORTREVISION= 0
CATEGORIES= x11
-MASTER_SITES= http://www.tecapli.com.ar/rodolfo/ \
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
http://nivi.interfree.it/distfiles/${PORTNAME}/
-EXTRACT_SUFX= .tbz2
MAINTAINER= nivit@FreeBSD.org
COMMENT= A quick launch bar for fluxbox, WindowMaker, Xfce, etc
-BUILD_DEPENDS= imlib2-config:${PORTSDIR}/graphics/imlib2
+RUN_DEPENDS= pidof:${PORTSDIR}/sysutils/pidof
-SUB_FILES= pkg-message
+CONFIGURE_ARGS= --exec-prefix=${PREFIX}
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_XORG= x11
+GNU_CONFIGURE= yes
-post-patch:
- ${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/Makefile
+MAN1= ${PORTNAME}.1 ${PORTNAME}-config.1
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR} && ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
- ${CAT} ${PKGMESSAGE}
+USE_EFL= imlib2
+# Disabled: the configure script has a couple of bugs...
+#.if !defined(WITHOUT_NLS)
+CONFIGURE_ENV= LIBS=-lintl
+USE_GETTEXT= yes
+PLIST_SUB= NLS=""
+#.else
+#CONFIGURE_ARGS+= --disable-nls
+#PLIST_SUB= NLS="@comment"
+#.endif
+USE_GMAKE= yes
+USE_GNOME= libglade2
.include <bsd.port.mk>