aboutsummaryrefslogtreecommitdiff
path: root/x11/wbar
diff options
context:
space:
mode:
Diffstat (limited to 'x11/wbar')
-rw-r--r--x11/wbar/Makefile42
-rw-r--r--x11/wbar/pkg-plist4
2 files changed, 13 insertions, 33 deletions
diff --git a/x11/wbar/Makefile b/x11/wbar/Makefile
index dac38b62a1f8..59e748063543 100644
--- a/x11/wbar/Makefile
+++ b/x11/wbar/Makefile
@@ -9,58 +9,34 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
EXTRACT_SUFX= .tgz
MAINTAINER= nivit@FreeBSD.org
-COMMENT= A quick launch bar for fluxbox, WindowMaker, Xfce, etc
+COMMENT= quick launch bar for fluxbox, WindowMaker, Xfce, etc
LICENSE= GPLv3
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
-USES= pkgconfig
+USES= pkgconfig gettext gmake
+USE_EFL= imlib2
GNU_CONFIGURE= yes
-MAN1= ${PORTNAME}.1
-MANLANG= "" es
-
OPTIONS_DEFINE= NLS WBARCONFIG
OPTIONS_DEFAULT= NLS WBARCONFIG
+OPTIONS_SUB= yes
WBARCONFIG_DESC= Build the GTK+ configuration interface
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+= --enable-nls
-CONFIGURE_ENV= LIBS=-lintl
-PLIST_SUB= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB= NLS="@comment "
-# The configure script has a couple of bugs...
-post-patch:
- ${REINPLACE_CMD} -e "s,install-data-@USE_NLS@,install-data-no,g" ${WRKSRC}/po/Makefile.in.in
-.endif
+NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_ENV= LIBS=-lintl
-.if ${PORT_OPTIONS:MWBARCONFIG}
-CONFIGURE_ARGS+= --enable-wbar-config
-PLIST_SUB+= WBARCONFIG=""
-MAN1+= ${PORTNAME}-config.1
-USE_GNOME= libglade2
-.else
-CONFIGURE_ARGS+= --disable-wbar-config
-PLIST_SUB+= WBARCONFIG="@comment "
-.endif
-
-USE_EFL= imlib2
-USES+= gettext gmake
-USE_GNOME+= desktopfileutils intltool
+WBARCONFIG_CONFIGURE_ENABLE= wbar-config
+WBARCONFIG_USE= GNOME=libglade2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_SUB+= DESKTOPDIR=${DESKTOPDIR:S,${PREFIX}/,,}
post-install:
- ${MV} ${PREFIX}/etc/wbar.d/wbar.desktop ${DESKTOPDIR}/wbar.desktop
+ ${MV} ${STAGEDIR}${PREFIX}/etc/wbar.d/wbar.desktop ${STAGEDIR}${DESKTOPDIR}/wbar.desktop
.include <bsd.port.mk>
diff --git a/x11/wbar/pkg-plist b/x11/wbar/pkg-plist
index 18f0ed7e4f60..590740e1c195 100644
--- a/x11/wbar/pkg-plist
+++ b/x11/wbar/pkg-plist
@@ -2,6 +2,10 @@ bin/wbar
%%WBARCONFIG%%bin/wbar-config
etc/bash_completion.d/wbar
etc/wbar.d/wbar.cfg
+%%WBARCONFIG%%man/es/man1/wbar-config.1.gz
+man/es/man1/wbar.1.gz
+%%WBARCONFIG%%man/man1/wbar-config.1.gz
+man/man1/wbar.1.gz
%%DESKTOPDIR%%/wbar.desktop
%%NLS%%share/locale/de/LC_MESSAGES/wbar.mo
%%NLS%%share/locale/es/LC_MESSAGES/wbar.mo