aboutsummaryrefslogtreecommitdiff
path: root/x11/wdm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/wdm/Makefile')
-rw-r--r--x11/wdm/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/x11/wdm/Makefile b/x11/wdm/Makefile
index 6982223d3076..a69cfcf4dc8b 100644
--- a/x11/wdm/Makefile
+++ b/x11/wdm/Makefile
@@ -51,7 +51,19 @@ pre-everything:
post-patch:
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/*.man
+pre-install:
+ @if [ -e ${PREFIX}/lib/X11/wdm/wdm-config ]; then \
+ ${MV} ${PREFIX}/lib/X11/wdm/wdm-config \
+ ${PREFIX}/lib/X11/wdm/wdm-config.preserve; \
+ fi
+
post-install:
- ${INSTALL_DATA} ${_DISTDIR}/${DAEMONPIC} ${PREFIX}/lib/X11/wdm/pixmaps
+ @${CP} ${PREFIX}/lib/X11/wdm/wdm-config \
+ ${PREFIX}/lib/X11/wdm/wdm-config.dist;
+ @if [ -e ${PREFIX}/lib/X11/wdm/wdm-config.preserve ]; then \
+ ${MV} ${PREFIX}/lib/X11/wdm/wdm-config.preserve \
+ ${PREFIX}/lib/X11/wdm/wdm-config; \
+ fi
+ @${INSTALL_DATA} ${_DISTDIR}/${DAEMONPIC} ${PREFIX}/lib/X11/wdm/pixmaps
.include <bsd.port.mk>