aboutsummaryrefslogtreecommitdiff
path: root/x11/xalf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xalf/Makefile')
-rw-r--r--x11/xalf/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11/xalf/Makefile b/x11/xalf/Makefile
new file mode 100644
index 000000000000..8b7d8032edea
--- /dev/null
+++ b/x11/xalf/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xalf
+# Date created: 27 March 2001
+# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xalf
+PORTVERSION= 0.11
+CATEGORIES= devel
+MASTER_SITES= http://www.lysator.liu.se/~astrand/projects/xalf/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ade@FreeBSD.org
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>