aboutsummaryrefslogtreecommitdiff
path: root/x11/xbindkeys/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xbindkeys/Makefile')
-rw-r--r--x11/xbindkeys/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11/xbindkeys/Makefile b/x11/xbindkeys/Makefile
new file mode 100644
index 000000000000..4872adbec8ac
--- /dev/null
+++ b/x11/xbindkeys/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: xbindkeys
+# Date created: Dec 29, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xbindkeys
+PORTVERSION= 1.0.1
+CATEGORIES= x11
+MASTER_SITES= http://hocwp.free.fr/xbindkeys/
+
+MAINTAINER= ports@FreeBSD.org
+
+WITH_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${X11BASE}/include"
+
+MAN1= xbindkeys.1 xbindkeys_show.1
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xbindkeysrc ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>