aboutsummaryrefslogtreecommitdiff
path: root/x11/xcb-util-image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xcb-util-image/Makefile')
-rw-r--r--x11/xcb-util-image/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11/xcb-util-image/Makefile b/x11/xcb-util-image/Makefile
new file mode 100644
index 000000000000..3ee602b7179a
--- /dev/null
+++ b/x11/xcb-util-image/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xcb-util-image
+# Date created: 2011-12-16
+# Whom: garga
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcb-util-image
+PORTVERSION= 0.3.8
+CATEGORIES= x11
+MASTER_SITES= http://xcb.freedesktop.org/dist/
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= A port of Xlib's XImage and XShmImage functions
+
+LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb \
+ xcb-util.0:${PORTSDIR}/x11/xcb-util
+#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+#USE_XORG= xau xdmcp
+#USE_AUTOTOOLS= libtool
+
+GNU_CONFIGURE= yes
+#CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf"
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>