aboutsummaryrefslogtreecommitdiff
path: root/x11/xdm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xdm/Makefile')
-rw-r--r--x11/xdm/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/x11/xdm/Makefile b/x11/xdm/Makefile
index 0e1025f15999..67578d1a322a 100644
--- a/x11/xdm/Makefile
+++ b/x11/xdm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xdm
PORTVERSION= 1.1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
@@ -15,7 +15,19 @@ COMMENT= X.Org X display manager
XORG_CAT= app
USE_XORG= xmu x11 xau xinerama xpm xdmcp xt xext xaw
+MAKE_ENV= EXAMPLESDIR=${EXAMPLESDIR}
MAN1= xdm.1
+CFFILES= GiveConsole TakeConsole Xaccess Xreset Xresources \
+ Xservers Xsession Xsetup_0 Xstartup Xwilling xdm-config
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,XDMCONFIGDIR,${PREFIX}/lib/X11/xdm,g" ${WRKSRC}/config/Xreset.cpp ${WRKSRC}/config/Xstartup.cpp
+
+post-install:
+.for f in ${CFFILES}
+ ${CP} -n ${EXAMPLESDIR}/$f ${PREFIX}/lib/X11/xdm/$f
+.endfor
+
.include <bsd.port.mk>