aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-screenshooter-plugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xfce4-screenshooter-plugin/Makefile')
-rw-r--r--x11/xfce4-screenshooter-plugin/Makefile30
1 files changed, 23 insertions, 7 deletions
diff --git a/x11/xfce4-screenshooter-plugin/Makefile b/x11/xfce4-screenshooter-plugin/Makefile
index e087557330b1..832b24fb3959 100644
--- a/x11/xfce4-screenshooter-plugin/Makefile
+++ b/x11/xfce4-screenshooter-plugin/Makefile
@@ -6,22 +6,38 @@
#
PORTNAME= xfce4-screenshooter-plugin
-PORTVERSION= 1.6.0
-PORTREVISION= 6
+PORTVERSION= 1.7.9
CATEGORIES= x11 xfce
-MASTER_SITES= http://goodies.xfce.org/releases/xfce4-screenshooter/
+MASTER_SITES= http://mocha.xfce.org/archive/src/apps/${PORTNAME:S/-plugin//}/${PORTVERSION:R}/
DISTNAME= xfce4-screenshooter-${PORTVERSION}
DIST_SUBDIR= xfce4
MAINTAINER= miwi@FreeBSD.org
COMMENT= Desktop Screenshot plugin for xfce
+LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup
+
+OPTIONS= NLS "Enable Native Language Support" on
+
+USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
INSTALLS_ICONS= yes
-USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv panel
+USE_GNOME= glib20 gtk20 intltool intlhack pkgconfig
+USE_XFCE= configenv panel libutil libgui
MAN1= xfce4-screenshooter.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PORTNAME%%|${PORTNAME}|g' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>