aboutsummaryrefslogtreecommitdiff
path: root/x11/xkeyboard-config/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xkeyboard-config/Makefile')
-rw-r--r--x11/xkeyboard-config/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11/xkeyboard-config/Makefile b/x11/xkeyboard-config/Makefile
new file mode 100644
index 000000000000..cb6ad0d295f1
--- /dev/null
+++ b/x11/xkeyboard-config/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: xkeyboard-config
+# Date Created: Dec 20 2006
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xkeyboard-config
+PORTVERSION= 0.9
+PORTREVISION= 2
+CATEGORIES= x11
+MASTER_SITES= http://xlibs.freedesktop.org/xkbdesc/
+DISTNAME= xkeyboard-config-${PORTVERSION}
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Keyboard Configuration Database
+
+BUILD_DEPENDS= xkbcomp:${PORTSDIR}/x11/xkbcomp \
+ ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+# XXX - sigh
+PREFIX= ${X11BASE}
+
+USE_BZIP2= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_PERL5_BUILD=yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-xkb-base=${PREFIX}/share/X11/xkb \
+ --with-xkb-rules-symlink=xorg
+
+post-install:
+ ${MKDIR} /var/lib/xkb
+
+.include <bsd.port.mk>