aboutsummaryrefslogtreecommitdiff
path: root/x11/xscreensaver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xscreensaver/Makefile')
-rw-r--r--x11/xscreensaver/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 7a863b195dc6..33bec5195604 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -6,20 +6,21 @@
#
PORTNAME= xscreensaver
-PORTVERSION= 3.26
+PORTVERSION= 3.29
CATEGORIES= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/
-MAINTAINER= jseger@FreeBSD.org
+MAINTAINER= DougB@FreeBSD.org
USE_X_PREFIX= yes
USE_XPM= yes
USE_MESA= yes
WANT_GTK= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-pam --with-gl --with-gle --with-xpm --without-gnome
+CONFIGURE_ARGS= --without-pam --with-gl --with-gle --with-xpm --without-gnome \
+ --with-zippy=/usr/games/fortune
-MAN1= attraction.1 blitspin.1 bouboule.1 braid.1 \
+MAN1= attraction.1 blitspin.1 bouboule.1 braid.1 \
bsod.1 bubbles.1 critical.1 decayscreen.1 \
deco.1 distort.1 drift.1 epicycle.1 flag.1 flame.1 \
forest.1 galaxy.1 gflux.1 goop.1 grav.1 greynetic.1 \
@@ -30,10 +31,15 @@ MAN1= attraction.1 blitspin.1 bouboule.1 braid.1 \
rd-bomb.1 rocks.1 rorschach.1 sierpinski.1 slidescreen.1 \
slip.1 sonar.1 sphere.1 spiral.1 spotlight.1 squiral.1 \
starfish.1 strange.1 swirl.1 t3d.1 vidwhacker.1 vines.1 \
- webcollage.1 xflame.1 xjack.1 xlyap.1 xmatrix.1 xroger.1 \
+ webcollage.1 xflame.1 xjack.1 xlyap.1 xmatrix.1 \
xscreensaver-command.1 xscreensaver-gl-helper.1 \
xscreensaver.1 xsublim.1 xteevee.1
+post-patch:
+ @ ${CP} ${WRKSRC}/configure ${WRKSRC}/configure.Patched
+ @ ${SED} -e 's#-lpthread#-pthread#g' \
+ ${WRKSRC}/configure.Patched > ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
.if defined(HAVE_GTK)