aboutsummaryrefslogtreecommitdiff
path: root/x11/xstroke/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xstroke/Makefile')
-rw-r--r--x11/xstroke/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11/xstroke/Makefile b/x11/xstroke/Makefile
index e502c245e8e5..5a2365ee3010 100644
--- a/x11/xstroke/Makefile
+++ b/x11/xstroke/Makefile
@@ -7,28 +7,30 @@
PORTNAME= xstroke
PORTVERSION= 0.5.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= ftp://ftp.handhelds.org/pub/projects/xstroke/release-${PORTVERSION:R}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Fullscreen gesture recognition
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt \
- Xft.2:${PORTSDIR}/x11-fonts/Xft
+LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/Xft
+PATCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/libgnugetopt:extract
USE_REINPLACE= yes
USE_BISON= yes
USE_IMAKE= yes
CFLAGS+= ${PTHREAD_CFLAGS}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+GETOPTDIR!= cd ${PORTSDIR}/devel/libgnugetopt; make -V WRKSRC
MAN1= xstroke.1
post-patch:
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/etc/Imakefile
@${REINPLACE_CMD} -e "s,etc/,${PREFIX}/etc/,g" ${WRKSRC}/args.h
+ ${CP} ${GETOPTDIR}/getopt* ${WRKSRC}
.include <bsd.port.mk>