aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/kde4-baseapps/Makefile3
-rw-r--r--x11/kde4-runtime/Makefile3
-rw-r--r--x11/kde4-workspace/Makefile3
-rw-r--r--x11/kdebase2/Makefile3
-rw-r--r--x11/kdebase3/Makefile3
-rw-r--r--x11/kdebase4-runtime/Makefile3
-rw-r--r--x11/kdebase4-workspace/Makefile3
-rw-r--r--x11/kdebase4/Makefile3
-rw-r--r--x11/kdelibs2/Makefile3
-rw-r--r--x11/kdelibs3/Makefile3
-rw-r--r--x11/kdelibs4/Makefile3
11 files changed, 33 insertions, 0 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index fc841306aebc..20a23b1b6eaa 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -41,6 +41,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index fc841306aebc..20a23b1b6eaa 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -41,6 +41,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index fc841306aebc..20a23b1b6eaa 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -41,6 +41,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/x11/kdebase2/Makefile b/x11/kdebase2/Makefile
index fc841306aebc..20a23b1b6eaa 100644
--- a/x11/kdebase2/Makefile
+++ b/x11/kdebase2/Makefile
@@ -41,6 +41,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index fc841306aebc..20a23b1b6eaa 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -41,6 +41,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index fc841306aebc..20a23b1b6eaa 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -41,6 +41,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index fc841306aebc..20a23b1b6eaa 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -41,6 +41,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index fc841306aebc..20a23b1b6eaa 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -41,6 +41,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/x11/kdelibs2/Makefile b/x11/kdelibs2/Makefile
index ebf462d3e58c..bbfd19d1fbbc 100644
--- a/x11/kdelibs2/Makefile
+++ b/x11/kdelibs2/Makefile
@@ -47,6 +47,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
.if ${MACHINE_ARCH} == "alpha"
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index ebf462d3e58c..bbfd19d1fbbc 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -47,6 +47,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
.if ${MACHINE_ARCH} == "alpha"
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index ebf462d3e58c..bbfd19d1fbbc 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -47,6 +47,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
.if ${MACHINE_ARCH} == "alpha"