aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/p5-X11-Resolution/Makefile23
-rw-r--r--x11/p5-X11-Resolution/distinfo3
-rw-r--r--x11/p5-X11-Resolution/pkg-descr4
-rw-r--r--x11/p5-X11-Resolution/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 9c25e74e23c0..0ce01c23b462 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -238,6 +238,7 @@
SUBDIR += p5-X11-GUITest
SUBDIR += p5-X11-IdleTime
SUBDIR += p5-X11-Protocol
+ SUBDIR += p5-X11-Resolution
SUBDIR += padkey
SUBDIR += peeper
SUBDIR += pixman
diff --git a/x11/p5-X11-Resolution/Makefile b/x11/p5-X11-Resolution/Makefile
new file mode 100644
index 000000000000..05bb85159eda
--- /dev/null
+++ b/x11/p5-X11-Resolution/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: x11/p5-X11-Resolution
+# Date created: 2009-10-24 11:30
+# Whom: Zane C. Bowers
+#
+# $FreeBSD$
+#
+
+PORTNAME= X11-Resolution
+PORTVERSION= 0.0.0
+CATEGORIES= x11 perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Provides a method to get the resolution for a X11 screen
+
+RUN_DEPENDS= ${SITE_PERL}/X11/Protocol.pm:${PORTSDIR}/x11/p5-X11-Protocol
+
+PERL_CONFIGURE= yes
+
+MAN3= X11::Resolution.3
+
+.include <bsd.port.mk>
diff --git a/x11/p5-X11-Resolution/distinfo b/x11/p5-X11-Resolution/distinfo
new file mode 100644
index 000000000000..ae1bd8f793cd
--- /dev/null
+++ b/x11/p5-X11-Resolution/distinfo
@@ -0,0 +1,3 @@
+MD5 (X11-Resolution-0.0.0.tar.gz) = 0dd9797db9730e35e1f7eae834c0c43d
+SHA256 (X11-Resolution-0.0.0.tar.gz) = 6d106ae4a198fada9f1453fe486190244f1b3697cca1b00929465c20c2a90aa4
+SIZE (X11-Resolution-0.0.0.tar.gz) = 3191
diff --git a/x11/p5-X11-Resolution/pkg-descr b/x11/p5-X11-Resolution/pkg-descr
new file mode 100644
index 000000000000..8a9fb1228acf
--- /dev/null
+++ b/x11/p5-X11-Resolution/pkg-descr
@@ -0,0 +1,4 @@
+X11::Resolution provides a method to easily get the resolution
+of screens in X11.
+
+WWW: http://search.cpan.org/dist/X11-Resolution/
diff --git a/x11/p5-X11-Resolution/pkg-plist b/x11/p5-X11-Resolution/pkg-plist
new file mode 100644
index 000000000000..a042f4d073e1
--- /dev/null
+++ b/x11/p5-X11-Resolution/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/X11/Resolution.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/Resolution/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/Resolution
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11
+@dirrmtry %%SITE_PERL%%/X11