aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/kde2/Makefile.kde37
-rw-r--r--x11/kde3/Makefile.kde37
-rw-r--r--x11/kde4-baseapps/Makefile17
-rw-r--r--x11/kde4-runtime/Makefile17
-rw-r--r--x11/kde4-workspace/Makefile17
-rw-r--r--x11/kde4/Makefile.kde37
-rw-r--r--x11/kdebase2/Makefile17
-rw-r--r--x11/kdebase3/Makefile17
-rw-r--r--x11/kdebase4-runtime/Makefile17
-rw-r--r--x11/kdebase4-workspace/Makefile17
-rw-r--r--x11/kdebase4/Makefile17
-rw-r--r--x11/kdelibs2/Makefile19
-rw-r--r--x11/kdelibs3/Makefile19
-rw-r--r--x11/kdelibs4/Makefile19
14 files changed, 130 insertions, 174 deletions
diff --git a/x11/kde2/Makefile.kde b/x11/kde2/Makefile.kde
new file mode 100644
index 000000000000..58fe75a64083
--- /dev/null
+++ b/x11/kde2/Makefile.kde
@@ -0,0 +1,37 @@
+# This is a simple set of Makefile macros which allow the core kde ports to
+# bring these in automatically since it's tiring to modify all of them to
+# add more of these. These don't belong in bsd.kde.mk because they aren't
+# very likely to apply outside of KDE core modules. Nonetheless, also
+# provide variables to remove one or more of these.
+#
+# $FreeBSD$
+
+CONFIGURE_ARGS?=
+
+.if !defined(_NO_KDE_OBJPRELINK)
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
+.endif
+
+.if !defined(_NO_KDE_FINAL)
+.if defined(PARALLEL_PACKAGE_BUILD) || !defined(NO_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.endif
+
+.if !defined(_NO_KDE_NDEBUG)
+.if defined(PARALLEL_PACKAGE_BUILD) || !defined(WANT_KDE_DEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
+.endif
+.endif
+
+.if !defined(_NO_KDE_NON_I386_OPTS)
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS= -O0 ${KDE_CFLAGS}
+.endif
+.endif
diff --git a/x11/kde3/Makefile.kde b/x11/kde3/Makefile.kde
new file mode 100644
index 000000000000..58fe75a64083
--- /dev/null
+++ b/x11/kde3/Makefile.kde
@@ -0,0 +1,37 @@
+# This is a simple set of Makefile macros which allow the core kde ports to
+# bring these in automatically since it's tiring to modify all of them to
+# add more of these. These don't belong in bsd.kde.mk because they aren't
+# very likely to apply outside of KDE core modules. Nonetheless, also
+# provide variables to remove one or more of these.
+#
+# $FreeBSD$
+
+CONFIGURE_ARGS?=
+
+.if !defined(_NO_KDE_OBJPRELINK)
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
+.endif
+
+.if !defined(_NO_KDE_FINAL)
+.if defined(PARALLEL_PACKAGE_BUILD) || !defined(NO_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.endif
+
+.if !defined(_NO_KDE_NDEBUG)
+.if defined(PARALLEL_PACKAGE_BUILD) || !defined(WANT_KDE_DEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
+.endif
+.endif
+
+.if !defined(_NO_KDE_NON_I386_OPTS)
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS= -O0 ${KDE_CFLAGS}
+.endif
+.endif
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index 20a23b1b6eaa..1173bb45a718 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -33,20 +30,10 @@ CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
--without-ldap --disable-closure
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
.include <bsd.port.pre.mk>
.if exists(${X11BASE}/include/Xm/Xm.h)
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 20a23b1b6eaa..1173bb45a718 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -33,20 +30,10 @@ CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
--without-ldap --disable-closure
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
.include <bsd.port.pre.mk>
.if exists(${X11BASE}/include/Xm/Xm.h)
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 20a23b1b6eaa..1173bb45a718 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -33,20 +30,10 @@ CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
--without-ldap --disable-closure
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
.include <bsd.port.pre.mk>
.if exists(${X11BASE}/include/Xm/Xm.h)
diff --git a/x11/kde4/Makefile.kde b/x11/kde4/Makefile.kde
new file mode 100644
index 000000000000..58fe75a64083
--- /dev/null
+++ b/x11/kde4/Makefile.kde
@@ -0,0 +1,37 @@
+# This is a simple set of Makefile macros which allow the core kde ports to
+# bring these in automatically since it's tiring to modify all of them to
+# add more of these. These don't belong in bsd.kde.mk because they aren't
+# very likely to apply outside of KDE core modules. Nonetheless, also
+# provide variables to remove one or more of these.
+#
+# $FreeBSD$
+
+CONFIGURE_ARGS?=
+
+.if !defined(_NO_KDE_OBJPRELINK)
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
+.endif
+
+.if !defined(_NO_KDE_FINAL)
+.if defined(PARALLEL_PACKAGE_BUILD) || !defined(NO_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.endif
+
+.if !defined(_NO_KDE_NDEBUG)
+.if defined(PARALLEL_PACKAGE_BUILD) || !defined(WANT_KDE_DEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
+.endif
+.endif
+
+.if !defined(_NO_KDE_NON_I386_OPTS)
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS= -O0 ${KDE_CFLAGS}
+.endif
+.endif
diff --git a/x11/kdebase2/Makefile b/x11/kdebase2/Makefile
index 20a23b1b6eaa..1173bb45a718 100644
--- a/x11/kdebase2/Makefile
+++ b/x11/kdebase2/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -33,20 +30,10 @@ CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
--without-ldap --disable-closure
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
.include <bsd.port.pre.mk>
.if exists(${X11BASE}/include/Xm/Xm.h)
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index 20a23b1b6eaa..1173bb45a718 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -33,20 +30,10 @@ CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
--without-ldap --disable-closure
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
.include <bsd.port.pre.mk>
.if exists(${X11BASE}/include/Xm/Xm.h)
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index 20a23b1b6eaa..1173bb45a718 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -33,20 +30,10 @@ CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
--without-ldap --disable-closure
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
.include <bsd.port.pre.mk>
.if exists(${X11BASE}/include/Xm/Xm.h)
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index 20a23b1b6eaa..1173bb45a718 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -33,20 +30,10 @@ CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
--without-ldap --disable-closure
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
.include <bsd.port.pre.mk>
.if exists(${X11BASE}/include/Xm/Xm.h)
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 20a23b1b6eaa..1173bb45a718 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -33,20 +30,10 @@ CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
--without-ldap --disable-closure
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
.include <bsd.port.pre.mk>
.if exists(${X11BASE}/include/Xm/Xm.h)
diff --git a/x11/kdelibs2/Makefile b/x11/kdelibs2/Makefile
index bbfd19d1fbbc..51a2c7d8f2be 100644
--- a/x11/kdelibs2/Makefile
+++ b/x11/kdelibs2/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= automake14:${PORTSDIR}/devel/automake14 \
autoconf213:${PORTSDIR}/devel/autoconf213
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
fam.0:${PORTSDIR}/devel/fam \
@@ -39,22 +36,8 @@ USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-cups --disable-ltdl-install
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
-.if ${MACHINE_ARCH} == "alpha"
-CFLAGS= -O0 ${KDE_CFLAGS} -D__PATH_SU=/usr/bin/su
-.endif
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
USE_GMAKE= yes
MAKE_ENV= SOMAJOR="${SOMAJOR}" SOMINOR="${SOMINOR}"
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index bbfd19d1fbbc..51a2c7d8f2be 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= automake14:${PORTSDIR}/devel/automake14 \
autoconf213:${PORTSDIR}/devel/autoconf213
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
fam.0:${PORTSDIR}/devel/fam \
@@ -39,22 +36,8 @@ USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-cups --disable-ltdl-install
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
-.if ${MACHINE_ARCH} == "alpha"
-CFLAGS= -O0 ${KDE_CFLAGS} -D__PATH_SU=/usr/bin/su
-.endif
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
USE_GMAKE= yes
MAKE_ENV= SOMAJOR="${SOMAJOR}" SOMINOR="${SOMINOR}"
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index bbfd19d1fbbc..51a2c7d8f2be 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -17,9 +17,6 @@ MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= automake14:${PORTSDIR}/devel/automake14 \
autoconf213:${PORTSDIR}/devel/autoconf213
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
fam.0:${PORTSDIR}/devel/fam \
@@ -39,22 +36,8 @@ USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-cups --disable-ltdl-install
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
-.if ${MACHINE_ARCH} == "alpha"
-CFLAGS= -O0 ${KDE_CFLAGS} -D__PATH_SU=/usr/bin/su
-.endif
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
USE_GMAKE= yes
MAKE_ENV= SOMAJOR="${SOMAJOR}" SOMINOR="${SOMINOR}"