aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libxfce4mcs/Makefile34
-rw-r--r--x11/libxfce4mcs/distinfo1
-rw-r--r--x11/libxfce4mcs/pkg-descr3
-rw-r--r--x11/libxfce4mcs/pkg-plist15
5 files changed, 54 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 1e6ae0167a6b..922f679d5399 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -75,6 +75,7 @@
SUBDIR += libgnomemm
SUBDIR += libpanel
SUBDIR += libsx
+ SUBDIR += libxfce4mcs
SUBDIR += libxklavier
SUBDIR += linux-gnomelibs
SUBDIR += login.app
diff --git a/x11/libxfce4mcs/Makefile b/x11/libxfce4mcs/Makefile
new file mode 100644
index 000000000000..62cee155ef51
--- /dev/null
+++ b/x11/libxfce4mcs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libxfce4util
+# Date created: 7 June 2003
+# Whom: James Earl <jdearl@telus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxfce4mcs
+PORTVERSION= 3.99.2
+CATEGORIES= x11
+MASTER_SITES= http://www.xfce.org/archive/xfce4-rc2/src/ \
+ ftp://ftp.unix-ag.org/user/bmeurer/xfce4/rc2/separate/ \
+ http://usuarios.lycos.es/xfce4/tarballs/rc2/separate/ \
+ http://linux.imp.mx/xfce4/rc2/xfce4-rc2/src/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= XFce 4 settings management library used by most XFce 4 modules
+
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util
+
+USE_GNOME= glib20
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ ${WRKSRC}/${PORTNAME}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11/libxfce4mcs/distinfo b/x11/libxfce4mcs/distinfo
new file mode 100644
index 000000000000..d92c45f16dba
--- /dev/null
+++ b/x11/libxfce4mcs/distinfo
@@ -0,0 +1 @@
+MD5 (xfce4/libxfce4mcs-3.99.2.tar.gz) = 83d6289f5d678cee262cb8ebdfcbd54e
diff --git a/x11/libxfce4mcs/pkg-descr b/x11/libxfce4mcs/pkg-descr
new file mode 100644
index 000000000000..7cc53b9ab7a9
--- /dev/null
+++ b/x11/libxfce4mcs/pkg-descr
@@ -0,0 +1,3 @@
+XFce 4 settings management library used by most XFce 4 modules.
+
+WWW: http://www.xfce.org
diff --git a/x11/libxfce4mcs/pkg-plist b/x11/libxfce4mcs/pkg-plist
new file mode 100644
index 000000000000..cc7d1a25f5a0
--- /dev/null
+++ b/x11/libxfce4mcs/pkg-plist
@@ -0,0 +1,15 @@
+include/xfce4/libxfce4mcs/mcs-client.h
+include/xfce4/libxfce4mcs/mcs-common.h
+include/xfce4/libxfce4mcs/mcs-manager.h
+lib/libxfce4mcs-client.a
+lib/libxfce4mcs-client.la
+lib/libxfce4mcs-client.so
+lib/libxfce4mcs-client.so.1
+lib/libxfce4mcs-manager.a
+lib/libxfce4mcs-manager.la
+lib/libxfce4mcs-manager.so
+lib/libxfce4mcs-manager.so.1
+libdata/pkgconfig/libxfce4mcs-manager-1.0.pc
+libdata/pkgconfig/libxfce4mcs-client-1.0.pc
+@dirrm include/xfce4/libxfce4mcs
+@unexec rmdir %D/include/xfce4 2>/dev/null || true