aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/avant-window-navigator/Makefile2
-rw-r--r--x11/avant-window-navigator/files/patch-libawn-settings.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/x11/avant-window-navigator/Makefile b/x11/avant-window-navigator/Makefile
index 7bab1ca5d331..dffb16df5897 100644
--- a/x11/avant-window-navigator/Makefile
+++ b/x11/avant-window-navigator/Makefile
@@ -7,7 +7,7 @@
PORTNAME= avant-window-navigator
PORTVERSION= 0.3.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://launchpadlibrarian.net/26374006/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/x11/avant-window-navigator/files/patch-libawn-settings.c b/x11/avant-window-navigator/files/patch-libawn-settings.c
new file mode 100644
index 000000000000..9482b5a960be
--- /dev/null
+++ b/x11/avant-window-navigator/files/patch-libawn-settings.c
@@ -0,0 +1,14 @@
+
+--- libawn/awn-settings.old.c 2009-12-05 08:14:18.000000000 +0000
++++ libawn/awn-settings.c 2009-12-05 08:14:31.000000000 +0000
+@@ -139,7 +139,7 @@
+
+ AwnSettings *s = NULL;
+
+- s = g_new(AwnSettings, 1);
++ s = g_new0(AwnSettings, 1);
+
+ settings = s;
+
+
+