aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/gdm/Makefile3
-rw-r--r--x11/gnome-applets/Makefile3
-rw-r--r--x11/gnome-session/Makefile9
-rw-r--r--x11/guake/Makefile2
4 files changed, 6 insertions, 11 deletions
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index 24ce6bd06a98..ddff41028a9e 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -36,8 +36,7 @@ USE_XORG= dmx dmxproto
INSTALLS_ICONS= yes
USE_RC_SUBR= gdm
USE_GNOME_SUBR= yes
-USE_GMAKE= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= intlhack gnomehier gconf2 librsvg2 \
gnomedocutils gnomeprefix gnomepanel
GCONF_SCHEMAS= gdm-simple-greeter.schemas
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 36f8261099fc..52f6aed1d184 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -23,11 +23,10 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/system-tools-backends-2.0.pc:${PORTS
${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-settings-daemon
USE_BZIP2= yes
-USE_GMAKE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix intlhack gnomepanel gnomedocutils libgnomekbd
WANT_GNOME= yes
USE_GSTREAMER= yes
diff --git a/x11/gnome-session/Makefile b/x11/gnome-session/Makefile
index e2c88c82e725..52201590e191 100644
--- a/x11/gnome-session/Makefile
+++ b/x11/gnome-session/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gnomesession
-# Date created: 08 May 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/x11/gnome-session/Makefile,v 1.187 2010/11/17 12:00:11 kwm Exp $
-#
PORTNAME= gnome-session
PORTVERSION= 2.32.1
@@ -29,12 +25,11 @@ RUN_DEPENDS= ${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gno
${LOCALBASE}/bin/xdpyinfo:${PORTSDIR}/x11/xdpyinfo
INSTALLS_ICONS= yes
-USES= gettext
+USES= gettext gmake pkgconfig
USE_BZIP2= yes
USE_XORG= ice sm xau xrandr
USE_GNOME= gnomeprefix gnomehack intlhack gconf2
GNOME_DESKTOP_VERSION=2
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-docbook-docs
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11/guake/Makefile b/x11/guake/Makefile
index 01abebb43a3b..640904beb702 100644
--- a/x11/guake/Makefile
+++ b/x11/guake/Makefile
@@ -27,6 +27,8 @@ INSTALLS_ICONS= yes
OPTIONS_DEFINE= MANPAGES NLS
OPTIONS_DEFAULT= MANPAGES NLS
+
+USES= pkgconfig
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMANPAGES}