aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/rofi/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/x11/rofi/Makefile b/x11/rofi/Makefile
index 7a4c81792fe7..695b19c1a797 100644
--- a/x11/rofi/Makefile
+++ b/x11/rofi/Makefile
@@ -11,8 +11,6 @@ COMMENT= Window switcher, run dialog and dmenu replacement
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= checkmk:devel/check \
- ${LOCALBASE}/bin/flex:textproc/flex
LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
libxcb-ewmh.so:x11/xcb-util-wm \
libxcb-icccm.so:x11/xcb-util-wm \
@@ -20,16 +18,17 @@ LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
libxcb-xrm.so:x11/xcb-util-xrm \
libxkbcommon-x11.so:x11/libxkbcommon
-USES= bison gmake gnome libtool pkgconfig shebangfix xorg
+USES= bison gnome meson pkgconfig shebangfix xorg
USE_GNOME= cairo gdkpixbuf2 librsvg2 pango
USE_XORG= xcb
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LEX="${LOCALBASE}/bin/flex"
SHEBANG_FILES= script/get_git_rev.sh \
script/rofi-sensible-terminal
bash_CMD= /bin/sh
-TEST_TARGET= check
+
+OPTIONS_DEFINE= TEST
+
+TEST_BUILD_DEPENDS= checkmk:devel/check
+TEST_MESON_ENABLED= check
post-patch:
# Fix rofi-theme-selector which assumes we have GNU sed