From 377f94001ecce1038c9fb22084fa4c7c9aae75d3 Mon Sep 17 00:00:00 2001
From: Kai Knoblich <kai@FreeBSD.org>
Date: Sun, 27 Oct 2019 19:10:05 +0000
Subject: [NEW PORT] devel/py-pyhcl

Implements a parser for HCL (HashiCorp Configuration Language) in Python.
This implementation aims to be compatible with the original golang version of
the parser.

The grammar and many of the tests/fixtures were copied/ported from the golang
parser into pyhcl. All releases are tested with a variety of Python versions
from Python 2.7 onward.

WWW: https://github.com/virtuald/pyhcl

PR:		241309
Submitted by:	Alessando Sagratini <ale_sagra@hotmail.com>
---
 devel/Makefile           |  1 +
 devel/py-pyhcl/Makefile  | 27 +++++++++++++++++++++++++++
 devel/py-pyhcl/distinfo  |  3 +++
 devel/py-pyhcl/pkg-descr |  9 +++++++++
 4 files changed, 40 insertions(+)
 create mode 100644 devel/py-pyhcl/Makefile
 create mode 100644 devel/py-pyhcl/distinfo
 create mode 100644 devel/py-pyhcl/pkg-descr

(limited to 'devel')

diff --git a/devel/Makefile b/devel/Makefile
index 53d92ad7c68a..9f8ff155160e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4856,6 +4856,7 @@
     SUBDIR += py-pygithub
     SUBDIR += py-pygpx
     SUBDIR += py-pyhashxx
+    SUBDIR += py-pyhcl
     SUBDIR += py-pyicu
     SUBDIR += py-pyinotify
     SUBDIR += py-pyinstaller
diff --git a/devel/py-pyhcl/Makefile b/devel/py-pyhcl/Makefile
new file mode 100644
index 000000000000..62bcb321d32b
--- /dev/null
+++ b/devel/py-pyhcl/Makefile
@@ -0,0 +1,27 @@
+# Created by: Alessando Sagratini <ale_sagra@hotmail.com>
+# $FreeBSD$
+
+PORTNAME=	pyhcl
+PORTVERSION=	0.3.12
+CATEGORIES=	devel python
+MASTER_SITES=	CHEESESHOP
+PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER=	ale_sagra@hotmail.com
+COMMENT=	HCL configuration parser for Python
+
+LICENSE=	MPL20
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+BUILD_DEPENDS=	${PYTHON_PKGNAMEPREFIX}ply>=3.8<4:devel/py-ply@${PY_FLAVOR}
+TEST_DEPENDS=	${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES=		python
+USE_PYTHON=	autoplist concurrent distutils
+
+NO_ARCH=	yes
+
+do-test:
+	@cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
+
+.include <bsd.port.mk>
diff --git a/devel/py-pyhcl/distinfo b/devel/py-pyhcl/distinfo
new file mode 100644
index 000000000000..76893cb79701
--- /dev/null
+++ b/devel/py-pyhcl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1571214531
+SHA256 (pyhcl-0.3.12.tar.gz) = 1ac02b5659df22fe36d0afbb6e258cd78085dd41f0b0c57be0f041ef32baae43
+SIZE (pyhcl-0.3.12.tar.gz) = 21739
diff --git a/devel/py-pyhcl/pkg-descr b/devel/py-pyhcl/pkg-descr
new file mode 100644
index 000000000000..05e0689bc00d
--- /dev/null
+++ b/devel/py-pyhcl/pkg-descr
@@ -0,0 +1,9 @@
+Implements a parser for HCL (HashiCorp Configuration Language) in Python.
+This implementation aims to be compatible with the original golang version of
+the parser.
+
+The grammar and many of the tests/fixtures were copied/ported from the golang
+parser into pyhcl. All releases are tested with a variety of Python versions
+from Python 2.7 onward.
+
+WWW: https://github.com/virtuald/pyhcl
-- 
cgit v1.2.3