From 96519d4f3e324365340eab678e35890a7e842e86 Mon Sep 17 00:00:00 2001
From: Martin Wilke <miwi@FreeBSD.org>
Date: Sun, 27 May 2007 21:49:08 +0000
Subject: GuiLoader is a high-performance and compact GuiXml loader library.
 This library allows GTK+ applications to create GUI widgets and objects at
 run-time from GuiXml resource files. GuiLoader is written in the C language
 as a GObject subclass and has a trivial language-independent API. GuiLoader
 was designed to be easily wrapped for any language that has GTK+ bindings.

WWW: http://crow-designer.sourceforge.net/

PR:		ports/112618
Submitted by:	Yinghong.Liu <liu_yinghong at yahoo.com.cn>
---
 devel/Makefile                |  1 +
 devel/guiloader-c++/Makefile  | 33 +++++++++++++++++++++++++++++++++
 devel/guiloader-c++/distinfo  |  3 +++
 devel/guiloader-c++/pkg-descr |  8 ++++++++
 devel/guiloader-c++/pkg-plist |  5 +++++
 5 files changed, 50 insertions(+)
 create mode 100644 devel/guiloader-c++/Makefile
 create mode 100644 devel/guiloader-c++/distinfo
 create mode 100644 devel/guiloader-c++/pkg-descr
 create mode 100644 devel/guiloader-c++/pkg-plist

(limited to 'devel')

diff --git a/devel/Makefile b/devel/Makefile
index aa92233ec400..3fe803a69331 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -418,6 +418,7 @@
     SUBDIR += guikachu
     SUBDIR += guile-lib
     SUBDIR += guiloader
+    SUBDIR += guiloader-c++
     SUBDIR += gwenhywfar
     SUBDIR += gzstream
     SUBDIR += hachoir-core
diff --git a/devel/guiloader-c++/Makefile b/devel/guiloader-c++/Makefile
new file mode 100644
index 000000000000..a9b7f97460ec
--- /dev/null
+++ b/devel/guiloader-c++/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for:	guiloader-c++
+# Date created:		11 May 2007
+# Whom:			Yinghong.Liu <liu_yinghong@yahoo.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	guiloader-c++
+PORTVERSION=	2.10.0
+CATEGORIES=	devel gnome
+MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=	crow-designer
+
+MAINTAINER=	liu_yinghong@yahoo.com.cn
+COMMENT=	A high-performance and compact GuiXml loader library
+
+LIB_PC_DEPENDS=	guiloader.pc:${PORTSDIR}/devel/guiloader
+
+LIB_DEPENDS+=	gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
+BUILD_DEPENDS+=	${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+RUN_DEPENDS+=	${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+
+USE_BZIP2=	yes
+USE_GETTEXT=	yes
+GNU_CONFIGURE=	yes
+USE_GNOME=	atk glib20 gtk20 pango
+USE_GMAKE=	yes
+
+post-patch:
+	@${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
+		${WRKSRC}/${PORTNAME}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/guiloader-c++/distinfo b/devel/guiloader-c++/distinfo
new file mode 100644
index 000000000000..b5de1267be39
--- /dev/null
+++ b/devel/guiloader-c++/distinfo
@@ -0,0 +1,3 @@
+MD5 (guiloader-c++-2.10.0.tar.bz2) = abd12eeadb8ecb8c3ec6f69be6e4e752
+SHA256 (guiloader-c++-2.10.0.tar.bz2) = f9849ce735dfd8acbea45e0609d035bc4429cc5bae0269543fd71abf07a04714
+SIZE (guiloader-c++-2.10.0.tar.bz2) = 244109
diff --git a/devel/guiloader-c++/pkg-descr b/devel/guiloader-c++/pkg-descr
new file mode 100644
index 000000000000..353123c34692
--- /dev/null
+++ b/devel/guiloader-c++/pkg-descr
@@ -0,0 +1,8 @@
+GuiLoader is a high-performance and compact GuiXml loader library.
+This library allows GTK+ applications to create GUI widgets and
+objects at run-time from GuiXml resource files. GuiLoader is
+written in the C language as a GObject subclass and has
+a trivial language-independent API. GuiLoader was designed to be
+easily wrapped for any language that has GTK+ bindings.
+
+WWW: http://crow-designer.sourceforge.net/
diff --git a/devel/guiloader-c++/pkg-plist b/devel/guiloader-c++/pkg-plist
new file mode 100644
index 000000000000..d16f4e1fd83b
--- /dev/null
+++ b/devel/guiloader-c++/pkg-plist
@@ -0,0 +1,5 @@
+include/guiloader-c++/guiloader-c++.h
+lib/libguiloader-c++.la
+lib/libguiloader-c++.so
+libdata/pkgconfig/guiloader-c++.pc
+@dirrm include/guiloader-c++
-- 
cgit v1.2.3