From f5fbcb77536313f69f55f3c2fc1326a26ca26300 Mon Sep 17 00:00:00 2001
From: Doug Barton <dougb@FreeBSD.org>
Date: Sun, 17 Mar 2002 06:47:25 +0000
Subject: Upgrade to the latest release candidate, 9.2.1rc1. Numerous 9.x bugs
 are fixed in this version, however BIND 9 is still recommended only for early
 adopters, and those that have time to closely monitor their name service.

* Change PORTNAME to bind9 so that 'pkg_add -r bind' does the right thing
* Use the local version of openssl, and disable threads on all but
the most recent -current. Thread support is still considered experimental.
---
 dns/bind94/Makefile  | 88 +++++++++++++++++++++++++++++++++++++---------------
 dns/bind94/distinfo  |  2 +-
 dns/bind94/pkg-plist | 56 +++++++++++++++++----------------
 3 files changed, 93 insertions(+), 53 deletions(-)

(limited to 'dns/bind94')

diff --git a/dns/bind94/Makefile b/dns/bind94/Makefile
index e0fa3e255862..2b8824bb3d6b 100644
--- a/dns/bind94/Makefile
+++ b/dns/bind94/Makefile
@@ -11,59 +11,97 @@
 # version. If you are concerned about using the most recent ISC
 # release you can generally build it cleanly from the source - Doug
 
-PORTNAME=	bind
-PORTVERSION=	9.1.3
+PORTNAME=	bind9
+PORTVERSION=	9.2.1rc1
 CATEGORIES=	net ipv6
 MASTER_SITES=	ftp://ftp.isc.org/isc/bind9/${PORTVERSION}/ \
 		ftp://ftp.nominum.com/pub/isc/bind9/${PORTVERSION}/ \
 		ftp://ftp.nerdc.ufl.edu/pub/mirrors/ftp.isc.org/isc/bind9/${PORTVERSION}/ \
 		ftp://ftp.sunet.se/pub/network/isc/bind9/${PORTVERSION}/ \
 		${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/bind9/${PORTVERSION}/,}
+DISTFILES=	bind-9.2.1rc1.tar.gz
 
 MAINTAINER=	DougB@FreeBSD.org
 
 GNU_CONFIGURE=	yes
-CONFIGURE_ARGS=	--localstatedir=/var
+CONFIGURE_ARGS=	--localstatedir=/var --disable-linux-caps
 
-MAN1=	dig.1 host.1 named-checkconf.1 named-checkzone.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 400014
+USE_OPENSSL=	yes
+CONFIGURE_ARGS+=	--with-openssl=${OPENSSLBASE}
+.endif
+
+.if ${OSVERSION} > 500030
+CONFIGURE_ARGS+=	--enable-threads
+.else
+CONFIGURE_ARGS+=	--disable-threads
+.endif
+
+MAN1=	dig.1 host.1
+MAN3=	lwres.3 lwres_addr_parse.3 lwres_buffer.3 lwres_buffer_add.3 \
+	lwres_buffer_back.3 lwres_buffer_clear.3 lwres_buffer_first.3 \
+	lwres_buffer_forward.3 lwres_buffer_getmem.3 lwres_buffer_getuint16.3 \
+	lwres_buffer_getuint32.3 lwres_buffer_getuint8.3 lwres_buffer_init.3 \
+	lwres_buffer_invalidate.3 lwres_buffer_putmem.3 \
+	lwres_buffer_putuint16.3 lwres_buffer_putuint32.3 \
+	lwres_buffer_putuint8.3 lwres_buffer_subtract.3 lwres_conf_clear.3 \
+	lwres_conf_get.3 lwres_conf_init.3 lwres_conf_parse.3 \
+	lwres_conf_print.3 lwres_config.3 lwres_context.3 \
+	lwres_context_allocmem.3 lwres_context_create.3 \
+	lwres_context_destroy.3 lwres_context_freemem.3 \
+	lwres_context_initserial.3 lwres_context_nextserial.3 \
+	lwres_context_sendrecv.3 lwres_endhostent.3 lwres_endhostent_r.3 \
+	lwres_freeaddrinfo.3 lwres_freehostent.3 lwres_gabn.3 \
+	lwres_gabnrequest_free.3 lwres_gabnrequest_parse.3 \
+	lwres_gabnrequest_render.3 lwres_gabnresponse_free.3 \
+	lwres_gabnresponse_parse.3 lwres_gabnresponse_render.3 \
+	lwres_gai_strerror.3 lwres_getaddrinfo.3 lwres_getaddrsbyname.3 \
+	lwres_gethostbyaddr.3 lwres_gethostbyaddr_r.3 lwres_gethostbyname.3 \
+	lwres_gethostbyname2.3 lwres_gethostbyname_r.3 lwres_gethostent.3 \
+	lwres_gethostent_r.3 lwres_getipnode.3 lwres_getipnodebyaddr.3 \
+	lwres_getipnodebyname.3 lwres_getnamebyaddr.3 lwres_getnameinfo.3 \
+	lwres_getrrsetbyname.3 lwres_gnba.3 lwres_gnbarequest_free.3 \
+	lwres_gnbarequest_parse.3 lwres_gnbarequest_render.3 \
+	lwres_gnbaresponse_free.3 lwres_gnbaresponse_parse.3 \
+	lwres_gnbaresponse_render.3 lwres_herror.3 lwres_hstrerror.3 \
+	lwres_inetntop.3 lwres_lwpacket_parseheader.3 \
+	lwres_lwpacket_renderheader.3 lwres_net_ntop.3 lwres_noop.3 \
+	lwres_nooprequest_free.3 lwres_nooprequest_parse.3 \
+	lwres_nooprequest_render.3 lwres_noopresponse_free.3 \
+	lwres_noopresponse_parse.3 lwres_noopresponse_render.3 \
+	lwres_packet.3 lwres_resutil.3 lwres_sethostent.3 \
+	lwres_sethostent_r.3 lwres_string_parse.3
 MAN5=	rndc.conf.5
-MAN8=	lwresd.8 named.8 nsupdate.8 rndc.8 dnssec-keygen.8 dnssec-makekeyset.8 \
-	dnssec-signkey.8 dnssec-signzone.8
+MAN8=	dnssec-keygen.8 dnssec-makekeyset.8 dnssec-signkey.8 dnssec-signzone.8 \
+	lwresd.8 named-checkconf.8 named-checkzone.8 named.8 nsupdate.8 \
+	rndc-confgen.8 rndc.8
 
-DIR=	${WRKSRC}/doc/man/bin
+WRKSRC=	${WRKDIR}/bind-${PORTVERSION}
+DIR=	${WRKSRC}/bin/
 post-patch:
-.for FILE in named-checkconf.1 named.8 nsupdate.8 rndc.8 rndc.conf.5
+.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.8 \
+	rndc/rndc.8
 	@ ${MV} ${DIR}/${FILE} ${DIR}/${FILE}.Dist
 	@ ${SED} -e 's#/etc/named.conf#${PREFIX}/etc/named.conf#g' \
 		-e 's#/etc/rndc.conf#${PREFIX}/etc/rndc.conf#g' \
 		${DIR}/${FILE}.Dist > ${DIR}/${FILE}
 .endfor
 
-	@ ${MV} ${WRKSRC}/doc/man/dnssec/dnssec-signzone.8 \
-		${WRKSRC}/doc/man/dnssec/dnssec-signzone.8.Dist
-	@ ${SED} -e 's#/etc/named.conf#${PREFIX}/etc/named.conf#g' \
-		${WRKSRC}/doc/man/dnssec/dnssec-signzone.8.Dist \
-		> ${WRKSRC}/doc/man/dnssec/dnssec-signzone.8
-
-	@ ${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.Dist
-	@ ${SED} -e 's#{INSTALL_PROGRAM}#{INSTALL_DATA} -m 555#g' \
-		${WRKSRC}/Makefile.in.Dist > ${WRKSRC}/Makefile.in
-
 post-install:
-.for NUM in 1 5 8
-	${INSTALL_MAN} ${WRKSRC}/doc/man/bin/*.${NUM} ${MANPREFIX}/man/man${NUM}
-.endfor
-	${INSTALL_MAN} ${WRKSRC}/doc/man/dnssec/*.8 ${MANPREFIX}/man/man8
 	${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
 		${PREFIX}/etc/rndc.conf.sample
 
 .if !defined(NOPORTDOCS)
 	${MKDIR} ${PREFIX}/share/doc/bind9/arm
 	${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM*html \
-		${PREFIX}/share/doc/bind9/arm/
-	${CP} -R ${WRKSRC}/doc/misc ${PREFIX}/share/doc/bind9/
+		${PREFIX}/share/doc/bind9/arm
+	${MKDIR} ${PREFIX}/share/doc/bind9/misc
+	${INSTALL_DATA} ${WRKSRC}/doc/misc/[a-z]* \
+		${PREFIX}/share/doc/bind9/misc
 	${CP} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/FAQ \
 		${WRKSRC}/README ${PREFIX}/share/doc/bind9/
 .endif
 
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/bind94/distinfo b/dns/bind94/distinfo
index 4652f70e6a31..a910839b1a8a 100644
--- a/dns/bind94/distinfo
+++ b/dns/bind94/distinfo
@@ -1 +1 @@
-MD5 (bind-9.1.3.tar.gz) = 1d52f78d5d0d38b7687543d79f0cf4c2
+MD5 (bind-9.2.1rc1.tar.gz) = 8eb02ab4ed0eb2d3b506a043f21cda82
diff --git a/dns/bind94/pkg-plist b/dns/bind94/pkg-plist
index 160688ac5194..1ef1ebb36905 100644
--- a/dns/bind94/pkg-plist
+++ b/dns/bind94/pkg-plist
@@ -12,21 +12,6 @@ include/dns/cache.h
 include/dns/callbacks.h
 include/dns/cert.h
 include/dns/compress.h
-include/dns/confacl.h
-include/dns/confcache.h
-include/dns/confcommon.h
-include/dns/confctl.h
-include/dns/confctx.h
-include/dns/confip.h
-include/dns/confkeys.h
-include/dns/conflog.h
-include/dns/conflsn.h
-include/dns/conflwres.h
-include/dns/confparser.h
-include/dns/confresolv.h
-include/dns/confrrset.h
-include/dns/confview.h
-include/dns/confzone.h
 include/dns/db.h
 include/dns/dbiterator.h
 include/dns/dbtable.h
@@ -47,7 +32,6 @@ include/dns/master.h
 include/dns/masterdump.h
 include/dns/message.h
 include/dns/name.h
-include/dns/namedconf.h
 include/dns/ncache.h
 include/dns/nxt.h
 include/dns/peer.h
@@ -68,6 +52,7 @@ include/dns/rootns.h
 include/dns/sdb.h
 include/dns/secalg.h
 include/dns/secproto.h
+include/dns/soa.h
 include/dns/ssu.h
 include/dns/tcpmsg.h
 include/dns/time.h
@@ -79,6 +64,7 @@ include/dns/validator.h
 include/dns/view.h
 include/dns/xfrin.h
 include/dns/zone.h
+include/dns/zonekey.h
 include/dns/zt.h
 include/dst/dst.h
 include/dst/lib.h
@@ -144,6 +130,7 @@ include/isc/stdio.h
 include/isc/stdtime.h
 include/isc/string.h
 include/isc/symtab.h
+include/isc/syslog.h
 include/isc/task.h
 include/isc/taskpool.h
 include/isc/thread.h
@@ -151,6 +138,21 @@ include/isc/time.h
 include/isc/timer.h
 include/isc/types.h
 include/isc/util.h
+include/isccc/alist.h
+include/isccc/base64.h
+include/isccc/cc.h
+include/isccc/ccmsg.h
+include/isccc/events.h
+include/isccc/lib.h
+include/isccc/result.h
+include/isccc/sexpr.h
+include/isccc/symtab.h
+include/isccc/symtype.h
+include/isccc/types.h
+include/isccc/util.h
+include/isccfg/cfg.h
+include/isccfg/check.h
+include/isccfg/log.h
 include/lwres/context.h
 include/lwres/int.h
 include/lwres/ipv6.h
@@ -163,16 +165,11 @@ include/lwres/net.h
 include/lwres/netdb.h
 include/lwres/platform.h
 include/lwres/result.h
-include/omapi/compatibility.h
-include/omapi/lib.h
-include/omapi/omapi.h
-include/omapi/private.h
-include/omapi/result.h
-include/omapi/types.h
 lib/libdns.a
 lib/libisc.a
+lib/libisccc.a
+lib/libisccfg.a
 lib/liblwres.a
-lib/libomapi.a
 sbin/dnssec-keygen
 sbin/dnssec-makekeyset
 sbin/dnssec-signkey
@@ -182,6 +179,7 @@ sbin/named
 sbin/named-checkconf
 sbin/named-checkzone
 sbin/rndc
+sbin/rndc-confgen
 %%PORTDOCS%%share/doc/bind9/CHANGES
 %%PORTDOCS%%share/doc/bind9/COPYRIGHT
 %%PORTDOCS%%share/doc/bind9/FAQ
@@ -197,16 +195,20 @@ sbin/rndc
 %%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.ch09.html
 %%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.html
 %%PORTDOCS%%share/doc/bind9/misc/dnssec
+%%PORTDOCS%%share/doc/bind9/misc/format-options.pl
 %%PORTDOCS%%share/doc/bind9/misc/ipv6
 %%PORTDOCS%%share/doc/bind9/misc/migration
 %%PORTDOCS%%share/doc/bind9/misc/migration-4to9
 %%PORTDOCS%%share/doc/bind9/misc/options
+%%PORTDOCS%%share/doc/bind9/misc/rfc-compliance
+%%PORTDOCS%%share/doc/bind9/misc/roadmap
 %%PORTDOCS%%share/doc/bind9/misc/sdb
 %%PORTDOCS%%@dirrm share/doc/bind9/arm
 %%PORTDOCS%%@dirrm share/doc/bind9/misc
 %%PORTDOCS%%@dirrm share/doc/bind9
-@dirrm include/omapi
-@dirrm include/lwres
-@dirrm include/isc
-@dirrm include/dst
 @dirrm include/dns
+@dirrm include/dst
+@dirrm include/isc
+@dirrm include/isccc
+@dirrm include/isccfg
+@dirrm include/lwres
-- 
cgit v1.2.3