From 9cc8e73a2808d9ff193e41a60dc63c57c9bbeb5a Mon Sep 17 00:00:00 2001
From: Dima Dorfman
Date: Thu, 28 Oct 2004 12:27:32 +0000
Subject: Add tuareg-mode, an Emacs major mode for editing Caml code
---
lang/tuareg-mode.el/Makefile | 45 +++++++++++++++++++++++++++++++++++++++++++
lang/tuareg-mode.el/distinfo | 2 ++
lang/tuareg-mode.el/pkg-descr | 17 ++++++++++++++++
3 files changed, 64 insertions(+)
create mode 100644 lang/tuareg-mode.el/Makefile
create mode 100644 lang/tuareg-mode.el/distinfo
create mode 100644 lang/tuareg-mode.el/pkg-descr
(limited to 'lang/tuareg-mode.el')
diff --git a/lang/tuareg-mode.el/Makefile b/lang/tuareg-mode.el/Makefile
new file mode 100644
index 000000000000..e3d88e2d21eb
--- /dev/null
+++ b/lang/tuareg-mode.el/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: tuareg-mode
+# Date created: 28 October 2004
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuareg-mode
+PORTVERSION= 1.41.5
+CATEGORIES= lang elisp
+MASTER_SITES= http://www-rocq.inria.fr/~acohen/tuareg/mode/
+
+MAINTAINER= dd@FreeBSD.org
+COMMENT= Emacs major mode for editing Caml code
+
+RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs20
+
+DOC_FILES= README HISTORY append-tuareg.el custom-tuareg.el
+DOC_DIR= share/doc/tuareg-mode
+ELISP_FILES= camldebug.el tuareg.el
+ELISP_DIR= share/emacs/site-lisp
+
+PLIST_FILES= ${ELISP_FILES:S/^/${ELISP_DIR}\//} \
+ ${ELISP_FILES:S/^/${ELISP_DIR}\//S/$/c/} \
+ ${DOC_FILES:S/^/${DOC_DIR}\//}
+PLIST_DIRS= ${DOC_DIR}
+
+do-build:
+.for __f in ${ELISP_FILES}
+ cd ${WRKSRC} && echo '(setq load-path (cons "." load-path)) \
+ (batch-byte-compile)' | \
+ emacs -batch -q -l /dev/stdin ${__f} 2> /dev/null
+.endfor
+
+do-install:
+.for __f in ${ELISP_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${__f} ${WRKSRC}/${__f}c \
+ ${PREFIX}/${ELISP_DIR}
+.endfor
+ ${MKDIR} ${PREFIX}/share/doc/tuareg-mode
+.for __f in ${DOC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${__f} ${PREFIX}/share/doc/tuareg-mode
+.endfor
+
+.include
diff --git a/lang/tuareg-mode.el/distinfo b/lang/tuareg-mode.el/distinfo
new file mode 100644
index 000000000000..a7b09b666c91
--- /dev/null
+++ b/lang/tuareg-mode.el/distinfo
@@ -0,0 +1,2 @@
+MD5 (tuareg-mode-1.41.5.tar.gz) = b43d32bcdb5521709b53f86d3e1c3ae7
+SIZE (tuareg-mode-1.41.5.tar.gz) = 51105
diff --git a/lang/tuareg-mode.el/pkg-descr b/lang/tuareg-mode.el/pkg-descr
new file mode 100644
index 000000000000..330de294451c
--- /dev/null
+++ b/lang/tuareg-mode.el/pkg-descr
@@ -0,0 +1,17 @@
+From the web site:
+
+ Tuareg is a Caml mode for GNU Emacs and XEmacs. It handles automatic
+ indentation of Objective Caml and Camllight codes. Key parts of the
+ code are hilighted using Font-Lock. Support to run an interactive
+ Caml toplevel and debbuger is provided.
+
+ This mode attempts to give better results than the one provided in
+ the standard distribution OCaml 3.x. Indentation rules are slightly
+ different but closer to classical functional languages.
+
+ There is no relation with the Tuareg People, except their reputation
+ of great CAMeL riders and breeders.
+
+Documentation is installed into share/doc/tuareg-mode
+
+WWW: http://www-rocq.inria.fr/~acohen/tuareg/
--
cgit v1.2.3