From 78f32b51680f0abea5de706a847a892b8c59ea70 Mon Sep 17 00:00:00 2001
From: Dima Dorfman
Date: Sat, 28 Jul 2001 17:46:33 +0000
Subject: Add rmime: decode MIME messages inside Emacs (works with RMAIL, VM,
and mh-e).
---
mail/rmime/Makefile | 34 ++++++++++++++++++++++++++++++++++
mail/rmime/distinfo | 1 +
mail/rmime/pkg-comment | 1 +
mail/rmime/pkg-descr | 6 ++++++
mail/rmime/pkg-plist | 2 ++
5 files changed, 44 insertions(+)
create mode 100644 mail/rmime/Makefile
create mode 100644 mail/rmime/distinfo
create mode 100644 mail/rmime/pkg-comment
create mode 100644 mail/rmime/pkg-descr
create mode 100644 mail/rmime/pkg-plist
(limited to 'mail/rmime')
diff --git a/mail/rmime/Makefile b/mail/rmime/Makefile
new file mode 100644
index 000000000000..f8629b5d076d
--- /dev/null
+++ b/mail/rmime/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: rmime
+# Date created: 28 July 2001
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= rmime
+PORTVERSION= 1.2
+CATEGORIES= mail
+MASTER_SITES= http://www.cinti.net/~rmoody/rmime/ \
+ ${MASTER_SITE_LOCAL} \
+ http://www.unixfreak.org/~dima/distfiles/
+MASTER_SITE_SUBDIR= dd
+DISTNAME= rmime.el
+EXTRACT_SUFX= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= dd@FreeBSD.org
+
+BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs20
+
+NO_WRKSUBDIR= yes
+STRIP= # empty
+
+do-build:
+ ${CP} ${DISTDIR}/rmime.el ${WRKDIR}
+ emacs -batch -f batch-byte-compile ${WRKDIR}/rmime.el
+
+do-install:
+ ${INSTALL_DATA} ${WRKDIR}/rmime.el ${WRKDIR}/rmime.elc\
+ ${PREFIX}/share/emacs/site-lisp
+
+.include
diff --git a/mail/rmime/distinfo b/mail/rmime/distinfo
new file mode 100644
index 000000000000..d38604c516dc
--- /dev/null
+++ b/mail/rmime/distinfo
@@ -0,0 +1 @@
+MD5 (rmime.el) = 6b18b7855077ce9373d94474b801747d
diff --git a/mail/rmime/pkg-comment b/mail/rmime/pkg-comment
new file mode 100644
index 000000000000..dd0e38d579a1
--- /dev/null
+++ b/mail/rmime/pkg-comment
@@ -0,0 +1 @@
+Decode MIME messages inside Emacs (works with RMAIL, VM, and mh-e)
diff --git a/mail/rmime/pkg-descr b/mail/rmime/pkg-descr
new file mode 100644
index 000000000000..f5cce11118c0
--- /dev/null
+++ b/mail/rmime/pkg-descr
@@ -0,0 +1,6 @@
+RMIME provides MIME support for several Emacs message reading
+packages. RMIME has been designed with RMAIL in mind, but it has also
+been tested with mh-e and VM. It should work with most other major
+modes as well.
+
+WWW: http://www.cinti.net/~rmoody/rmime/
diff --git a/mail/rmime/pkg-plist b/mail/rmime/pkg-plist
new file mode 100644
index 000000000000..5b745a743d86
--- /dev/null
+++ b/mail/rmime/pkg-plist
@@ -0,0 +1,2 @@
+share/emacs/site-lisp/rmime.el
+share/emacs/site-lisp/rmime.elc
--
cgit v1.2.3