From 233ed4ecef12e2583178e64f2b381550ef07706c Mon Sep 17 00:00:00 2001
From: Gerald Pfeifer <gerald@FreeBSD.org>
Date: Sun, 21 Jan 2018 18:21:55 +0000
Subject: Fix the build on FreeBSD 12+ by using a current version of GCC which
 is already used by some of the dependencies.

This avoids build errors of the following kind:

  /lib/libgcc_s.so.1: version GCC_4.6.0 required by
  /usr/local/lib/gcc6/libgfortran.so.3 not found

Submitted by:	maintainer (Rainer Hurling <rhurlin@gwdg.de>)
PR:		225230
---
 science/mpb/Makefile | 4 ++++
 1 file changed, 4 insertions(+)

(limited to 'science')

diff --git a/science/mpb/Makefile b/science/mpb/Makefile
index 5e6e96fe9f12..a36d60d06c80 100644
--- a/science/mpb/Makefile
+++ b/science/mpb/Makefile
@@ -33,6 +33,10 @@ NLOPT_LIB_DEPENDS=	libnlopt.so:math/nlopt
 
 .include <bsd.port.options.mk>
 
+.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1200051
+USE_GCC=	yes
+.endif
+
 .if ${PORT_OPTIONS:MATLAS}
 LIB_DEPENDS+=	libatlas.so:math/atlas
 CONFIGURE_ARGS+=	--with-lapack=-lalapack
-- 
cgit v1.2.3