# Created by: Jesse McConnell <jesse@cylant.com>
# $FreeBSD$

PORTNAME=	entity
PORTVERSION=	0.7.2
PORTREVISION=	5
CATEGORIES=	devel
MASTER_SITES=	SF/${PORTNAME}/${PORTNAME}/Old%20Entity%20Versions

MAINTAINER=	ports@FreeBSD.org
COMMENT=	A really rapid XML-based application development system

LIB_DEPENDS=	pcre:${PORTSDIR}/devel/pcre
RUN_DEPENDS=	python:${PORTSDIR}/lang/python

GNU_CONFIGURE=	yes
CONFIGURE_ARGS+=	--enable-tcl=no

USES=		perl5
USE_AUTOTOOLS=	libtool
USE_GMAKE=	yes
USE_GNOME=	gtk12
USE_LDCONFIG=	${PREFIX}/lib/entity/clib
MAKE_JOBS_UNSAFE=	yes

MAN1=		entity.1

NO_STAGE=	yes
.include <bsd.port.pre.mk>

post-install:
	${MKDIR} ${PREFIX}/share/entity
	cd ${WRKSRC}/apps && ${PAX} -r -w `${LS} | \
		${GREP} -v Makefile` ${PREFIX}/share/entity

.include <bsd.port.post.mk>