# New ports collection makefile for: HTML/Template for Ruby
# Date created: 28 February 2003
# Whom: Akinori MUSHA aka knu
#
# $FreeBSD$
#
PORTNAME= html-template
PORTVERSION= 0.16
CATEGORIES= textproc www ruby
MASTER_SITES= http://shebang.jp/src/ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
MAINTAINER= ports@FreeBSD.org
COMMENT= A Ruby library to use HTML as a template file from CGI scripts
USE_RUBY= yes
USE_RUBY_SETUP= yes
RUBY_SETUP= install.rb
DOCS_EN= ChangeLog \
README \
html-template.rd
DOCS_JA= html-template.ja.rd
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${CP} -R ${WRKSRC}/example/ ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.for f in ${DOCS_JA}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
.endfor
.endif
.include