# New ports collection makefile for: p5-HTML-Tree
# Date created: 3 January 2000
# Whom: Dmitry Sivachenko
#
# $FreeBSD$
#
PORTNAME= HTML-Tree
PORTVERSION= 3.23
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= A collection of modules to manupulate HTML syntax trees
BUILD_DEPENDS= p5-HTML-Parser>=2.19:${PORTSDIR}/www/p5-HTML-Parser \
p5-HTML-Tagset>=3.02:${PORTSDIR}/www/p5-HTML-Tagset
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= HTML::Parse.3 HTML::TreeBuilder.3 HTML::AsSubs.3 \
HTML::Element.3 HTML::Element::traverse.3 HTML::Tree.3 \
HTML::Tree::Scanning.3 HTML::Tree::AboutObjects.3 \
HTML::Tree::AboutTrees.3
.include
.if ${PERL_LEVEL} < 500600
post-patch:
${PERL} -pi -e 's/our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/t/*.t
${PERL} -pi -e 's,-Tw,-,; s/(use|no) warnings;.*//' ${WRKSRC}/t/*.t
.endif
.include