summaryrefslogtreecommitdiff
path: root/ld/configure.in
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2010-10-19 21:13:25 +0000
committerDimitry Andric <dim@FreeBSD.org>2010-10-19 21:13:25 +0000
commit7a815afd9b5121ee0f65dc1e1de1c0de6de97679 (patch)
treef61b968a46c92e81f6de581582cb064bf9dca27d /ld/configure.in
parent42f6b9ffef1927d55d15075d9e810435c590c404 (diff)
Notes
Diffstat (limited to 'ld/configure.in')
-rw-r--r--ld/configure.in55
1 files changed, 26 insertions, 29 deletions
diff --git a/ld/configure.in b/ld/configure.in
index 4358cbe0bb23e..e020288c00c02 100644
--- a/ld/configure.in
+++ b/ld/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script
dnl
-AC_PREREQ(2.13)
+AC_PREREQ(2.57)
AC_INIT(ldmain.c)
AC_CANONICAL_SYSTEM
@@ -66,26 +66,7 @@ AC_SUBST(use_sysroot)
AC_SUBST(TARGET_SYSTEM_ROOT)
AC_SUBST(TARGET_SYSTEM_ROOT_DEFINE)
-build_warnings="-W -Wall -Wstrict-prototypes -Wmissing-prototypes"
-AC_ARG_ENABLE(build-warnings,
-[ --enable-build-warnings enable build-time compiler warnings if gcc is used],
-[case "${enableval}" in
- yes) ;;
- no) build_warnings="-w";;
- ,*) t=`echo "${enableval}" | sed -e "s/,/ /g"`
- build_warnings="${build_warnings} ${t}";;
- *,) t=`echo "${enableval}" | sed -e "s/,/ /g"`
- build_warnings="${t} ${build_warnings}";;
- *) build_warnings=`echo "${enableval}" | sed -e "s/,/ /g"`;;
-esac
-if test x"$silent" != x"yes" && test x"$build_warnings" != x""; then
- echo "Setting warning flags = $build_warnings" 6>&1
-fi])dnl
-WARN_CFLAGS=""
-if test "x${build_warnings}" != x -a "x$GCC" = xyes ; then
- WARN_CFLAGS="${build_warnings}"
-fi
-AC_SUBST(WARN_CFLAGS)
+AM_BINUTILS_WARNINGS
AM_CONFIG_HEADER(config.h:config.in)
@@ -101,7 +82,7 @@ fi
AC_PROG_CC
AC_PROG_INSTALL
-ALL_LINGUAS="fr sv tr es da"
+ALL_LINGUAS="fr sv tr es da vi zh_CN"
CY_GNU_GETTEXT
AC_EXEEXT
@@ -118,17 +99,23 @@ AC_SUBST(HOSTING_CRT0)
AC_SUBST(HOSTING_LIBS)
AC_SUBST(NATIVE_LIB_DIRS)
-AC_CHECK_HEADERS(string.h strings.h stdlib.h unistd.h)
-AC_CHECK_FUNCS(sbrk realpath)
+AC_CHECK_HEADERS(string.h strings.h stdlib.h unistd.h elf-hints.h)
+AC_CHECK_FUNCS(sbrk realpath glob)
AC_HEADER_DIRENT
+AC_MSG_CHECKING(for a known getopt prototype in unistd.h)
+AC_CACHE_VAL(ld_cv_decl_getopt_unistd_h,
+[AC_TRY_COMPILE([#include <unistd.h>], [extern int getopt (int, char *const*, const char *);],
+ld_cv_decl_getopt_unistd_h=yes, ld_cv_decl_getopt_unistd_h=no)])
+AC_MSG_RESULT($ld_cv_decl_getopt_unistd_h)
+if test $ld_cv_decl_getopt_unistd_h = yes; then
+ AC_DEFINE([HAVE_DECL_GETOPT], 1,
+ [Is the prototype for getopt in <unistd.h> in the expected format?])
+fi
+
BFD_BINARY_FOPEN
-BFD_NEED_DECLARATION(strstr)
-BFD_NEED_DECLARATION(free)
-BFD_NEED_DECLARATION(sbrk)
-BFD_NEED_DECLARATION(getenv)
-BFD_NEED_DECLARATION(environ)
+AC_CHECK_DECLS([strstr, free, sbrk, getenv, environ])
# When converting linker scripts into strings for use in emulation
# files, use astring.sed if the compiler supports ANSI string
@@ -256,10 +243,20 @@ case "$target_vendor" in
hp) EXTRA_SHLIB_EXTENSION=".sl" ;;
*) EXTRA_SHLIB_EXTENSION= ;;
esac
+
+case "$target_os" in
+ lynxos) EXTRA_SHLIB_EXTENSION=".a" ;;
+esac
+
if test x${EXTRA_SHLIB_EXTENSION} != x ; then
AC_DEFINE_UNQUOTED(EXTRA_SHLIB_EXTENSION, "$EXTRA_SHLIB_EXTENSION",
[Additional extension a shared object might have.])
fi
+dnl Required by html and install-html
+AC_SUBST(datarootdir)
+AC_SUBST(docdir)
+AC_SUBST(htmldir)
+
AC_OUTPUT(Makefile po/Makefile.in:po/Make-in,
[sed -e '/POTFILES =/r po/POTFILES' po/Makefile.in > po/Makefile])