summaryrefslogtreecommitdiff
path: root/lib/Target/MSP430/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/MSP430/CMakeLists.txt')
-rw-r--r--lib/Target/MSP430/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/Target/MSP430/CMakeLists.txt b/lib/Target/MSP430/CMakeLists.txt
index 67017733cd9cf..60e0bb1856c32 100644
--- a/lib/Target/MSP430/CMakeLists.txt
+++ b/lib/Target/MSP430/CMakeLists.txt
@@ -10,14 +10,14 @@ tablegen(MSP430GenDAGISel.inc -gen-dag-isel)
tablegen(MSP430GenCallingConv.inc -gen-callingconv)
tablegen(MSP430GenSubtarget.inc -gen-subtarget)
-add_llvm_target(MSP430
- MSP430AsmPrinter.cpp
- MSP430FrameInfo.cpp
+add_llvm_target(MSP430CodeGen
MSP430InstrInfo.cpp
MSP430ISelDAGToDAG.cpp
MSP430ISelLowering.cpp
+ MSP430MCAsmInfo.cpp
MSP430RegisterInfo.cpp
MSP430Subtarget.cpp
- MSP430TargetAsmInfo.cpp
MSP430TargetMachine.cpp
)
+
+target_link_libraries (LLVMMSP430CodeGen LLVMSelectionDAG)