summaryrefslogtreecommitdiff
path: root/lib/libavl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libavl/Makefile.am')
-rw-r--r--lib/libavl/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/lib/libavl/Makefile.am b/lib/libavl/Makefile.am
new file mode 100644
index 0000000000000..6087b1d2f4a09
--- /dev/null
+++ b/lib/libavl/Makefile.am
@@ -0,0 +1,14 @@
+include $(top_srcdir)/config/Rules.am
+
+VPATH = $(top_srcdir)/module/avl/
+
+# Includes kernel code, generate warnings for large stack frames
+AM_CFLAGS += $(FRAME_LARGER_THAN)
+
+noinst_LTLIBRARIES = libavl.la
+
+KERNEL_C = \
+ avl.c
+
+nodist_libavl_la_SOURCES = \
+ $(KERNEL_C)