summaryrefslogtreecommitdiff
path: root/ELF/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2016-07-23 20:48:50 +0000
committerDimitry Andric <dim@FreeBSD.org>2016-07-23 20:48:50 +0000
commit1c98619801a5705c688e683be3ef9d70169a0686 (patch)
tree8422105cd1a94c368315f2db16b9ac746cf7c000 /ELF/CMakeLists.txt
parentf4f3ce4613680903220815690ad79fc7ba0a2e26 (diff)
downloadsrc-test2-1c98619801a5705c688e683be3ef9d70169a0686.tar.gz
src-test2-1c98619801a5705c688e683be3ef9d70169a0686.zip
Notes
Diffstat (limited to 'ELF/CMakeLists.txt')
-rw-r--r--ELF/CMakeLists.txt28
1 files changed, 26 insertions, 2 deletions
diff --git a/ELF/CMakeLists.txt b/ELF/CMakeLists.txt
index 3dcb65ff8957..a1b65adc7400 100644
--- a/ELF/CMakeLists.txt
+++ b/ELF/CMakeLists.txt
@@ -2,25 +2,49 @@ set(LLVM_TARGET_DEFINITIONS Options.td)
tablegen(LLVM Options.inc -gen-opt-parser-defs)
add_public_tablegen_target(ELFOptionsTableGen)
-add_lld_library(lldELF2
+add_lld_library(lldELF
Driver.cpp
DriverUtils.cpp
+ EhFrame.cpp
Error.cpp
+ ICF.cpp
InputFiles.cpp
InputSection.cpp
+ LTO.cpp
LinkerScript.cpp
MarkLive.cpp
OutputSections.cpp
+ Relocations.cpp
+ ScriptParser.cpp
+ Strings.cpp
+ SymbolListFile.cpp
SymbolTable.cpp
Symbols.cpp
Target.cpp
+ Thunks.cpp
Writer.cpp
LINK_COMPONENTS
+ ${LLVM_TARGETS_TO_BUILD}
+ Analysis
+ BitReader
+ BitWriter
+ Codegen
+ Core
+ IPO
+ Linker
+ LTO
Object
Option
+ Passes
MC
Support
+ Target
+ TransformUtils
+
+ LINK_LIBS
+ lldConfig
+ ${PTHREAD_LIB}
)
-add_dependencies(lldELF2 ELFOptionsTableGen)
+add_dependencies(lldELF intrinsics_gen ELFOptionsTableGen)