summaryrefslogtreecommitdiff
path: root/contrib/ntp/sntp/Makefile.am
diff options
context:
space:
mode:
authorOllivier Robert <roberto@FreeBSD.org>2004-07-20 15:01:56 +0000
committerOllivier Robert <roberto@FreeBSD.org>2004-07-20 15:01:56 +0000
commit9c2daa00c2315f101948c7144d62af5d5fb515cf (patch)
tree528d12dda44ebdc3ffcc38050f159ac553a69c17 /contrib/ntp/sntp/Makefile.am
parentba371819a70ed076ebef04af93922a043272bfbe (diff)
downloadsrc-test2-9c2daa00c2315f101948c7144d62af5d5fb515cf.tar.gz
src-test2-9c2daa00c2315f101948c7144d62af5d5fb515cf.zip
Notes
Diffstat (limited to 'contrib/ntp/sntp/Makefile.am')
-rw-r--r--contrib/ntp/sntp/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/contrib/ntp/sntp/Makefile.am b/contrib/ntp/sntp/Makefile.am
new file mode 100644
index 000000000000..ccb62d83b03d
--- /dev/null
+++ b/contrib/ntp/sntp/Makefile.am
@@ -0,0 +1,38 @@
+# Makefile for sntp
+# N.M. Maclaren, October 2000.
+
+# Take a look at README for the various preprocessor symbols, but they are
+# extremely unlikely to be needed on newer systems. You may prefer to change
+# LOCKNAME and SAVENAME to use /var/run (or even /tmp) rather than /etc. Note
+# that not all of the following system settings have been tested recently.
+
+AUTOMAKE_OPTIONS = foreign
+
+# Compiling this sort of ANSI C under SunOS 4.1 is a mug's game, because Sun's
+# Unix headers make GNU C vomit even in compatibility mode, but the following
+# will compile main.c and unix.c. At least two people have got it to work.
+# CC = gcc -ansi
+# CFLAGS = -O -DNONBLOCK_BROKEN
+# LDFLAGS =
+# LIBS = -lm
+
+# The following settings can be used under Linux. While adjtime is present,
+# it is completely broken (i.e. it will work only if xntp is running), so it
+# is a good idea to add -DADJTIME_MISSING.
+# CC = cc -DADJTIME_MISSING
+# CFLAGS = -O
+# LDFLAGS =
+# LIBS = -lm
+
+bin_PROGRAMS = sntp
+sntp_SOURCES = \
+ header.h \
+ internet.c \
+ internet.h \
+ kludges.h \
+ main.c \
+ socket.c \
+ timing.c \
+ unix.c \
+ $(EMPTY)
+