summaryrefslogtreecommitdiff
path: root/ELF/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ELF/CMakeLists.txt')
-rw-r--r--ELF/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/ELF/CMakeLists.txt b/ELF/CMakeLists.txt
index 2e9d2b941fd9..41da497abe26 100644
--- a/ELF/CMakeLists.txt
+++ b/ELF/CMakeLists.txt
@@ -11,16 +11,19 @@ add_lld_library(lldELF
DriverUtils.cpp
EhFrame.cpp
Error.cpp
+ Filesystem.cpp
GdbIndex.cpp
ICF.cpp
InputFiles.cpp
InputSection.cpp
LTO.cpp
LinkerScript.cpp
+ MapFile.cpp
MarkLive.cpp
Mips.cpp
OutputSections.cpp
Relocations.cpp
+ ScriptLexer.cpp
ScriptParser.cpp
Strings.cpp
SymbolTable.cpp
@@ -53,7 +56,7 @@ add_lld_library(lldELF
LINK_LIBS
lldConfig
lldCore
- ${PTHREAD_LIB}
+ ${LLVM_PTHREAD_LIB}
DEPENDS
ELFOptionsTableGen