summaryrefslogtreecommitdiff
path: root/MinGW/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'MinGW/CMakeLists.txt')
-rw-r--r--MinGW/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/MinGW/CMakeLists.txt b/MinGW/CMakeLists.txt
new file mode 100644
index 000000000000..bb0fe4a3887d
--- /dev/null
+++ b/MinGW/CMakeLists.txt
@@ -0,0 +1,23 @@
+set(LLVM_TARGET_DEFINITIONS Options.td)
+tablegen(LLVM Options.inc -gen-opt-parser-defs)
+add_public_tablegen_target(MinGWOptionsTableGen)
+
+if(NOT LLD_BUILT_STANDALONE)
+ set(tablegen_deps intrinsics_gen)
+endif()
+
+add_lld_library(lldMinGW
+ Driver.cpp
+
+ LINK_COMPONENTS
+ Option
+ Support
+
+ LINK_LIBS
+ lldCOFF
+ lldCommon
+
+ DEPENDS
+ MinGWOptionsTableGen
+ ${tablegen_deps}
+)