summaryrefslogtreecommitdiff
path: root/contrib/cvs/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/cvs/configure.in')
-rw-r--r--contrib/cvs/configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/contrib/cvs/configure.in b/contrib/cvs/configure.in
index 29070257b743..c60e98f4927b 100644
--- a/contrib/cvs/configure.in
+++ b/contrib/cvs/configure.in
@@ -63,7 +63,7 @@ AC_TYPE_MODE_T
AC_TYPE_SIZE_T
AC_TYPE_PID_T
AC_STRUCT_ST_BLKSIZE
-AC_REPLACE_FUNCS(mkdir rename strstr dup2 strerror valloc waitpid memmove vasprintf strtoul)
+AC_REPLACE_FUNCS(mkdir rename strstr dup2 strerror valloc waitpid memmove strtoul)
AC_CHECK_FUNCS(fchmod fsync ftime mktemp putenv vprintf ftruncate timezone getpagesize initgroups fchdir sigaction sigprocmask sigvec sigsetmask sigblock tempnam tzset readlink wait3)
dnl
@@ -262,10 +262,12 @@ WITH_GSSAPI
hold_cppflags=$CPPFLAGS
CPPFLAGS="$CPPFLAGS -I$GSSAPI/include "
-AC_CHECK_HEADERS(gssapi.h gssapi/gssapi.h gssapi/gssapi_generic.h)
+AC_CHECK_HEADERS(krb5.h gssapi.h gssapi/gssapi.h gssapi/gssapi_generic.h)
CPPFLAGS=$hold_cppflags
-if test "$ac_cv_header_gssapi_h" = "yes" || test "$ac_cv_header_gssapi_gssapi_h" = "yes"; then
+if test "$ac_cv_header_krb5_h" = "yes" &&
+ (test "$ac_cv_header_gssapi_h" = "yes" ||
+ test "$ac_cv_header_gssapi_gssapi_h" = "yes"); then
AC_DEFINE(HAVE_GSSAPI)
includeopt="${includeopt} -I$GSSAPI/include"
# FIXME: This is ugly, but these things don't seem to be standardized.
@@ -381,8 +383,8 @@ test -f src/options.h && (
)
AC_OUTPUT(Makefile lib/Makefile src/Makefile zlib/Makefile diff/Makefile doc/Makefile \
- man/Makefile tools/Makefile tools/pcl-cvs/Makefile \
- contrib/Makefile contrib/elib/Makefile \
+ man/Makefile tools/Makefile \
+ contrib/Makefile \
windows-NT/Makefile windows-NT/SCC/Makefile \
- os2/Makefile emx/Makefile macintosh/Makefile vms/Makefile \
+ os2/Makefile emx/Makefile vms/Makefile \
stamp-h)